strange glitch results in lost mail

Chris Yuzik chris at FRACTALWEB.COM
Mon Jul 14 18:54:10 IST 2003

Hi everyone,

I have SpamAssassin and MailScanner running on my RedHat 7.3 machine. The server is running Ensim WEBppliance PRO 3.5.10. The server hosts about a dozen domains. I run sendmail and procmail. Almost everything works great. Almost.

Mail from the outside world works as expected, gets scanned and scored and so forth. I've got SA's threshold set to 5 and am running DCC and the two days I tested it over the weekend, it correctly identified 99%+ of spam.

My big problem is that sometimes mail from within the server never arrives...never bounces...just goes to a black hole.

I'll list some examples so it makes more sense:

1) let's pretend that and are hosted on my server. is not hosted on my server.
2) steve at and john at can both sent to and receive email from susan at just fine. dave at and scott at can also sent to and receive email from susan at to. Internal to the outside world works.
3) steve at can not email john at and vice-versa. Internal to internal is not working.
4) it gets stranger. dave at can send email to scott at, but not the other way around. If scott replies to dave's message, then dave never gets the reply.

As I said before, the message doesn't bounce or just goes into a black hole and is never seen again.

When I installed MailScanner, the documentation said I was supposed to do the following (which is what I did):
1) "service sendmail stop"
2) "service MailScanner start"

In an attempt to troubleshoot the problem, I tried the following:
1) "service MailScanner stop"
2) "service sendmail start"
3) "service MailScanner start"

Now everyone can email everyone else: internal<-> internal and internal<->external just fine. Unfortunately, now nothing gets processed through spamassassin.

How do I go about fixing this?

Please help.

Chris Yuzik
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list