MailScanner not starting error

Chris Stone axisml at
Thu Jun 16 20:10:36 IST 2011


On Thu, Jun 16, 2011 at 12:21 PM, Kaplan, Andrew H.
<AHKAPLAN at> wrote:
> I ran the nslookup command on the server, and it was able to resolve the
> hostname. After that I stopped MailScanner via the
> /etc/init.d/MailScanner script, and followed up with the killall sendmail
> command. When I ran the ps -ef command immediately thereafter, I observed
> two defunct sendmail processes.
> After I restarted MailScanner, the two defunct processes were still present
> along with two 'regular' sendmail processes. The first of the two defunct
> processes disappeared after ten minutes, while the second one as of this
> e-mail continues to exist.

Try running:

service MailScanner stop
service sendmail stop
chkconfig MailScanner on
chkconfig sendmail off
killall -TERM sendmail
service MailScanner start

The MailScanner init script starts sendmail for you, so you need to
make sure the the 'normal' sendmail init script is disabled. The above
commands should do that all for you and after the last, you should
then see MailScanner (with sendmail) starting up successfully.


More information about the MailScanner mailing list