Betr.: Re: Notice to ruleset not being read - MS 4.78.15-1

Julian Field MailScanner at
Tue Sep 8 15:24:03 IST 2009

That is not from MailScanner itself, but from the hourly cron job which 
calls /usr/sbin/processing_messages_alert. You are quite correct that 
this script is incapable of handling rulesets.
I'm not overly convinced that is worth fixing as it's quite a lot of 
work for a tiny gain.
The easy thing would be to just default to the "localpostmaster" setting 
if it finds a ruleset. That would probably be better than the current 

Try the attached (compresssed) script instead of 
Remember to make it executable! ("chmod +x 

On 08/09/2009 15:06, Amelein at wrote:
> Just got another mail which it tried to send to filename at fqdn 
> <mailto:filename at fqdn>
> the contents of the message is:
> --
> Archive:
> Number of messages: 1
> Tries Message Last Tried
> ===== ======= ==========
> 6 5210725B3.AC562 Tue Sep  8 12:15:58 2009
> -- 
> MailScanner
> --
> If I remember correctly this  message triggered a crash loop 
> protection earlier because of a configuration error I hadn't 
> discovered till putting the server into the actual e-mail stream, I 
> had forgotten to update the language conf and it was looking for 
> something which wasn't in there.
> -
> Arjan


Julian Field MEng CITP CEng
Buy the MailScanner book at

Need help customising MailScanner?
Contact me!
Need help fixing or optimising your systems?
Contact me!
Need help getting you started solving new requirements from your boss?
Contact me!

PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654
Follow me at and

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

-------------- next part --------------
A non-text attachment was scrubbed...
Type: application/zip
Size: 736 bytes
Desc: not available
Url :

More information about the MailScanner mailing list