SOLVED in 7.2: Perl problems on FreeBSD (again)

Jose Amengual M pepe at
Mon Oct 26 18:53:47 GMT 2009


On 2009-10-26, at 11:45 AM, Mog wrote:

> Hi Jose,
> Thanks for your input on this. I will give your method a try on 6.4  
> tonight to see if it works. What has me confused about this though,  
> is that it just doesn't make sense...
> This has happened before with 5.8.x and moving to 5.10.0 solved it,  
> so what is different between 5.10.0 and 5.10.1?
I don't really know , I'm not a perl expert but it could be a new  
function implemented or a problem with the freebsd port....
> If it's just a problem with the upgrade process. Why doesn't  
> deleting perl, mailscanner and all the perl ports, and then  
> reinstalling them with the updated perl (5.10.1), make the problem  
> go away?
no, I tried that, actually I'm using on jails and I created a new  
clean jail and didn't work.
> People on the list say they have done fresh installs (so no  
> upgrading at all), but they still have the same perl errors everyone  
> else is experiencing after an upgrade. Again, if it's just a problem  
> with the upgrade process, why does this happen?
problem in the mailscanner code , maybe ?

> Obviously I don't expect you personally to have the answers to any  
> of these, but I'm hoping someone might be able to shed some light on  
> them at least. Like I said, it just doesn't make sense. There has to  
> be something specific that is actually causing this problem for  
> everyone using MailScanner on FreeBSD that essentially cripples a  
> mail server until the errors can be resolved, hopefully we can  
> eventually figure it out.
> Regards,
> mog
> Jose Amengual M wrote:
>> Hi Guys.
>> I saw some emails about perl 5.10.1 giving errors when running  
>> mailscanner, I had the same problem and I follow the instructions  
>> below but it din't work for me, but finally after 2 days of work I  
>> found the solution!!!.
>> This is working 7.2 should work on 8.0.
>> if you have already mailscanner installed don't worry, portupgrade  
>> can do all the job for you :).
>> 1.- Remove old perl version :
>> pkg_info|grep perl ( copy the exact name of you perl version like  
>> perl5.10.1 )
>> pkg_delete -f perl5.10.1
>> 2.- Install old perl.
>> pkg_add -r
>> 3.- Clean up any work directory
>> portsclean -C
>> 4.- Update pkgdb add upgrade any perl package
>> pkgdb -Ff
>> portupgrade -fr perl ( this is going to upgrade everything that  
>> uses perl including mailscanner).
>> perl-after-upgrade && perl-after-upgrade -f
>> After that the error was gone and everything was working fine.
>> I was in the process of deciding of going towards mailscanner or  
>> amavisd-new and I decided to use mailscanner because was easier to  
>> configure and I expend 2 days fixing a problem with perl that I  
>> didn't have on amavis :).
>> I hope this help.
>> Thanks.
>> Jose Amengual.
> -- 
> MailScanner mailing list
> mailscanner at
> Before posting, read
> Support MailScanner development - buy the book off the website!

Este mensaje ha sido analizado por MailScanner
en busca de virus y otros contenidos peligrosos,
y se considera que está limpio.
For all your IT requirements visit:

More information about the MailScanner mailing list