SOLVED in 7.2: Perl problems on FreeBSD (again)

Mog lists at
Sun Nov 15 14:03:34 GMT 2009


I followed the procedure you described exactly. I'm guessing the other 
people who are experiencing the same problem did the same thing as well 
(as mentioned on the ports mailing list). I'm using that exact version 
of perl you mentioned and used the perl-after-upgrade call as always. As 
it turns out, to get the mail server back up and running again I had to 
revert to the packaged version perl-5.10.0_2.tbz and ignore the upgrade 
(like last time this happened).

I can only assume that either you did something extra we haven't to make 
it work, or ... Actually there is no or, I'm out of ideas. I have no 
idea why it should work for a few people but not dozens of others 
(unless you're using portmaster and we're using portupgrade or 
something). Nor do I know what actually is the cause of the problem.

I can't see any logical reason why every so often a perl upgrade will 
cause MailScanner to break. Presumably either it's a recurring problem 
with the FreeBSD port, the upgrade process, or within perl itself.


Jose Amengual M wrote:
> This worked for me in a non fresh install and in a fresh install.
> you need to make sure that after you remove pearl you are installing pearl perl-5.10.0_2.tbz  need to be exctly this one.

More information about the MailScanner mailing list