Can't see the error of my ways - Clamd

Steve Campbell campbell at
Tue Nov 11 13:53:36 GMT 2008

Really frustated, as I should be able to see this.

I have installed the latest MS and the Clamd rpms on a machine, and 
then, after seeing that it is running fine, onto two other machines. The 
first is still running fine. The other two are reporting the error in my 

::ERROR:: UNKNOWN CLAMD RETURN ./lstat() failed. ERROR :: 

Now, I have tried to figure out where the ownership and permissions are 
going haywire, but haven't been able to. I am running sendmail.

I can stop MS, change the ownership of the incoming directory to 
clamav.root on the bad machine as it is on the nicely-running machine. 
When I start MS and it creates the first temp directory under incoming, 
it changes the ownership back to root.clamav for the directory incoming 
and the temp directories. I have tried comparing the MS.conf files and 
the clamd.conf files, but see no difference.

Does anyone have a clue?

I installed all 3 machines following the wiki instructions.

Thanks for any help

Steve Campbell

More information about the MailScanner mailing list