Can't see the error of my ways - Clamd

Julian Field MailScanner at
Tue Nov 11 14:15:33 GMT 2008

Steve Campbell wrote:
> Really frustated, as I should be able to see this.
> I have installed the latest MS and the Clamd rpms on a machine, and 
> then, after seeing that it is running fine, onto two other machines. 
> The first is still running fine. The other two are reporting the error 
> in my maillog:
> ::ERROR:: UNKNOWN CLAMD RETURN ./lstat() failed. ERROR :: 
> /var/spool/MailScanner/incoming/10897
> Now, I have tried to figure out where the ownership and permissions 
> are going haywire, but haven't been able to. I am running sendmail.
> I can stop MS, change the ownership of the incoming directory to 
> clamav.root on the bad machine as it is on the nicely-running machine. 
> When I start MS and it creates the first temp directory under 
> incoming, it changes the ownership back to root.clamav for the 
> directory incoming and the temp directories. I have tried comparing 
> the MS.conf files and the clamd.conf files, but see no difference.
> Does anyone have a clue?
Have you checked all the ownership and permissions settings in 
MailScanner.conf? I would suspect that's where your problem is, 
MailScanner will be overwriting your manually set permissions.


Julian Field MEng CITP CEng
Buy the MailScanner book at

Need help customising MailScanner?
Contact me!
Need help fixing or optimising your systems?
Contact me!
Need help getting you started solving new requirements from your boss?
Contact me!

PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the MailScanner mailing list