Mailscanner, CentOS 5, and updating perl.

Henry Kwan lists at
Wed Dec 10 19:42:33 GMT 2008

Kai Schaetzl <maillists <at>> writes:

> Henry Kwan wrote on Tue, 9 Dec 2008 22:52:02 +0000 (UTC):
> > So the offending rpm was this one that yum update wants me to install:
> > 
> > perl-Compress-Zlib.i386                  1.42-1.fc6             base
> why should "yum update" want you to install it? This is not an update. Is it 
> a dependancy?

Not sure.  I'm guessing it's because I installed perl-Compress-Zlib-1.41-1 
from Julian's tarball.

> > If I go ahead and install it, the same error as above always pops up when 
> > I go to start Mailscanner.
> Not here, with 1.42-1.fc6 on the system. However, my latest MS version 
> currently is 4.71.10. So, there may be something offending with a later
> version.

I was running 4.71.10-1 with 1.42-1.fc6 fine but when I tried upgrading to
4.73.4-2, that's when the error popped up.  So I removed 1.42-1.fc6 and 
downgrade to 1.41-1.

> Or it is caused by installing all those Perl source packages from Julian's 
> tarball. On RH/CentOS systems I strongly recommend *not* to install the 
> complete tar.gz you get from Julian's site. Unpack that and *only* (force-)
> install the mailscanner*.rpm plus the tnef rpm and I may be missing another 
> one. Install *all* the perl modules that are missing from rpmforge before 
> you install MailScanner. Also note, that some of the modules in the tar.gz 
> are already included in the installed Perl. There's no need to install 
> these.

Ok, I'll do a search for your old list and will try bringing up MS from only
installing the main mailscanner*.rpm and the 1 or 2 missing perl modules.

Though, after this exercise, I can see why having a dedicated repository is
so attractive.  :-)

Thanks for the response.


More information about the MailScanner mailing list