MailScanner -debug --lint... solved

Julian Field MailScanner at
Wed Apr 30 10:28:48 IST 2008

Hash: SHA1

Alessandro Dentella wrote:
> Hi,
>   While writing this message I found the misconfiguration that caused it. I
>   post the message anyhow since there is another message written 1 month ago
>   with the same problem that was left unanswered.
>   ----
>   I'm trying to debug a problem so I used --debug --lint discovering a
>   different behaviour according to the dir I run it from. I already saw a
>   message noticing the same thing:
>   If I run if from /root (PATH is correct, no ".") I  get:
> Cannot create temporary Work Dir /10768. Are the permissions and ownership
> of  correct? at /usr/share/MailScanner//MailScanner/ line 152
>   runnning it from /etc/MailScanner met another problem in a different
>   position. 
>   I found out I had wront permissios on /tmp!!! (chmod 1777 /tmp...)
What permissions and ownership did it have before? (when it was broken)


- -- 
Julian Field MEng CITP CEng
Buy the MailScanner book at

Need help customising MailScanner?
Contact me!
Need help fixing or optimising your systems?
Contact me!
Need help getting you started solving new requirements from your boss?
Contact me!

PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654

Version: PGP Desktop 9.8.2 (Build 3005)
Comment: Use Enigmail to decrypt or check this message is legitimate
Charset: ISO-8859-1


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the MailScanner mailing list