AW: MCP Check not working

Daniel Fuhrer daniel at
Thu Jun 21 06:35:31 IST 2007

Hi Glenn
Thanks for your answer.
I had a v320.pre (/usr/local/etc/mail/spamassassin/v320.pre) file. In there are the Lines:
# Check - Provides main check functionality
loadplugin Mail::SpamAssassin::Plugin::Check

# HTTPSMismatch - find URI mismatches between href and anchor text
loadplugin Mail::SpamAssassin::Plugin::HTTPSMismatch

So I tried to comment this out. But still not working. Then I tried to copy it to the mcp Directory (/usr/local/etc/MailScanner/mcp/). But without success.
In the same directory I have as well a v310.pre, v310.pre.sample and a v320.pre.sample

For me it look, that SpamAssassin is not loading the Plugin for some reason.

Cheer Daniel

-----Ursprüngliche Nachricht-----
Von: mailscanner-bounces at [mailto:mailscanner-bounces at] Im Auftrag von Glenn Steen
Gesendet: Mittwoch, 20. Juni 2007 16:07
An: Mailscanner
Betreff: Re: MCP Check not working

On 20/06/07, Daniel Fuhrer <daniel at> wrote:
> Hi Glenn
> Here is the output:
> check: no loaded plugin implements 'check_main': cannot scan! at /usr/local/lib/perl5/site_perl/5.8.8/Mail/SpamAssassin/ line 164.
The line above indicates the error... You don't have a v320.pre file
in /etc/MailScanner/mcp ... This is fixed in the latest (trust
Jules;), but apparantly not in the version you installed... You can
create it, it only need contain one line... Here is mine:
# cat /etc/MailScanner/mcp/v320.pre
# Check - Provides main check functionality
loadplugin Mail::SpamAssassin::Plugin::Check

then perhaps restart MailScanner to reinstantiate MCP.

> I don't understand what's wrong with the config directives " use_dcc 0", " use_pyzor 0", "use_razor1 0" and "use_razor2 0"?

Pretty much as with the actual error above... These are now
implemented in plugins, so ... if you don't load the plugin, you don't
have anything understanding the parameter:-).
MCP don't use, and don't need, those... One could argue that one
should make some IfPlugin statements around them, or just plan comment
them out... But they do no real harm either... And they are needed if
you run with an old SA (to implement MCP)... So just ignore those

> Is there a something wrong in the on line 164?
No. It is the fact that there is no handler for check_main that is the
problem, and it is cured by loading the plugin that now implements it.

> There is the following Code:
> 158:    # The primary check functionality occurs via a plugin call.  For more
> 159:    # information, please see: Mail::SpamAssassin::Plugin::Check
> 160:    if (!$self->{main}->call_plugins ("check_main", { permsgstatus => $self }))
> 161:            {
> 162:            # did anything happen?  if not, this is fatal
> 163:            if (!$self->{main}->have_plugin("check_main")) {
> 164:                    die "check: no loaded plugin implements 'check_main': cannot scan!";
> 165:            }
> 166:    }
> Hope that helps.
As do I:-)

> Cheers Daniel

Cheers to you too
-- Glenn
email: glenn < dot > steen < at > gmail < dot > com
work: glenn < dot > steen < at > ap1 < dot > se
MailScanner mailing list
mailscanner at

Before posting, read

Support MailScanner development - buy the book off the website! 

More information about the MailScanner mailing list