MCP Check not working

Glenn Steen glenn.steen at
Thu Jun 21 10:43:56 IST 2007

On 21/06/07, Daniel Fuhrer <daniel at> wrote:
> Hi Glenn
> Thanks for your answer.
> I had a v320.pre (/usr/local/etc/mail/spamassassin/v320.pre) file. In there are the Lines:

Daniel, stop right there and go back and read my last message again.
MCP is all about running a second _specially configured_ spamassassin
instance. It does not, nor should it, read the standard spamassassin
configuration files.

So please, undo the damage you did to your v320.pre in
/usr/etc/mail/spamassassin, and create a v320.pre in
/etc/MailScanner/mcp (which is where MCP needs it to be), as I
instructed in the previous message.

> # Check - Provides main check functionality
> #
> loadplugin Mail::SpamAssassin::Plugin::Check
> # HTTPSMismatch - find URI mismatches between href and anchor text
> #
> loadplugin Mail::SpamAssassin::Plugin::HTTPSMismatch
> So I tried to comment this out. But still not working. Then I tried to copy it to the mcp Directory (/usr/local/etc/MailScanner/mcp/). But without success.
> In the same directory I have as well a v310.pre, v310.pre.sample and a v320.pre.sample
> For me it look, that SpamAssassin is not loading the Plugin for some reason.

That is because you haven't considered what MCP is ... a _second,
separate_ invocation of spamassassin, that share _no_ configuration
with the normal spamassassin run by MailScanner.

The error is simply due to that second (MCP) invocation of
spamassassin not finding a function that previously used to be part of
spamassassin proper, but now is part of a plugin... so all you need do
is tell that instance what plugin to load. And that is the whole point
of the v320.pre file you need place in /etc/MailScanner/mcp ...

-- Glenn
email: glenn < dot > steen < at > gmail < dot > com
work: glenn < dot > steen < at > ap1 < dot > se

More information about the MailScanner mailing list