MailScanner lint errors?

Steve Campbell campbell at
Mon Feb 6 14:05:31 GMT 2006


I'm seeing the same with respect to the PID file. My conf file points to 
/var/run/ and the file does exist.

I'm also seeing the dual restart problem, where I am required to start MS 
twice if I stop it. I alway need to 'killall sendmail', but this doesn't 
cause the need to start MS twice. There are no sendmail processes running 
before I start MS. There are no log errors, it just doesn't start. I just 
thought I would mention this off-thread part in case it might have something 
to do with the PID problem.

MS 4.50-15
MailWatch 1.0.3
SA 3.10 (or whatever was the latest as of last week)
Tao Linux 1.0 Update 6


Steve Campbell
campbell at
Charleston Newspapers

----- Original Message ----- 
From: "Gerry Doris" <gdoris at>
To: "MailScanner discussion" <mailscanner at>
Sent: Sunday, February 05, 2006 3:12 PM
Subject: Re: MailScanner lint errors?

> Julian Field wrote:
>> I strongly suspect that none are relevant, apart from the Cannot write 
>> pid file error. Check this is set to something in your MailScanner.conf 
>> file.
> I checked MailScanner.conf and the MailScanner PID is set to 
> /var/run/  The file is really there and is being used.
> Like I said, there are no errors in any logs and mail is being sent and 
> received.  It was working but I can't remember the last time I tried it.
> I'm using the latest MailWatch.  Would that be confusing the MailScanner 
> lint operation?
>> Gerry Doris wrote:
>>> I've started seeing errors after running MailScanner --lint which I 
>>> haven't seen before.
>>> I was running 4.50.10 and decided to upgrade to 4.50.15 today. 
>>> Everything went well and MailScanner is working properly.  I see no 
>>> errors in any of the logs.  Mail is being accepted and delivered.
>>> MailScanner -v runs without errors but when I run MailScanner --lint I 
>>> get the following:
>>> [root at tiger MailScanner]# MailScanner --lint
>>> Read 701 hostnames from the phishing whitelist
>>> Config: calling custom init function SQLBlacklist
>>> Config: calling custom init function MailWatchLogging
>>> Config: calling custom init function SQLWhitelist
>>> Cannot write pid file , No such file or directory at 
>>> /usr/sbin/MailScanner line 1238
>>> Checking for SpamAssassin errors (if you use it)...
>>> Using SpamAssassin results cache
>>> Connected to SpamAssassin cache database
>>> SpamAssassin reported no errors.
>>> MailScanner.conf says "Virus Scanners = clamavmodule f-prot trend 
>>> bitdefender"
>>> Use of uninitialized value in split at 
>>> /usr/lib/MailScanner/MailScanner/ line 2879.
>>> Use of uninitialized value in concatenation (.) or string at 
>>> /usr/lib/MailScanner/MailScanner/ line 2880.
>>> Use of uninitialized value in concatenation (.) or string at 
>>> /usr/lib/MailScanner/MailScanner/ line 2880.
>>> Can't exec "-IsItInstalled": No such file or directory at 
>>> /usr/lib/MailScanner/MailScanner/ line 2882.
>>> ...snip
>>> the above is repeated 5 more times
>>> ...snip
>>> Found these virus scanners installed: bitdefender, f-prot, clamavmodule, 
>>> trend
> -- 
> MailScanner mailing list
> mailscanner at
> Before posting, read
> Support MailScanner development - buy the book off the website! 

More information about the MailScanner mailing list