Solaris 10 init.d startup failing

Jeff A. Earickson jaearick at
Tue Aug 29 16:59:43 IST 2006

On Fri, 25 Aug 2006, Rob Shepherd wrote:

> Date: Fri, 25 Aug 2006 12:50:49 +0100
> From: Rob Shepherd <rob at>
> Reply-To: MailScanner discussion <mailscanner at>
> To: MailScanner discussion <mailscanner at>
> Subject: Re: Solaris 10 init.d startup failing
> Jeff A. Earickson wrote:
>> If you can easily create a svcadm standalone setup for MailScanner, you
>> would be a hero to us few Solaris 10 users. 
> This is mine... works great.

Still no joy on this issue.  Your SMF manifest didn't work, nor did one
I constructed based on the sendmail manifest.  Still the same loop-up
problem at startup, just like with an old /etc/init.d script.

> NOTE: remove the check_mailscanner cron entry.  SMF will ensure it's up and 
> running (if it can be).... The ps grepping in check_mailscanner didn't work 
> for me (the pargs are too long and get chopped by ps) and spawned multiple 
> top-level MS processes.

Did you make any changes to check_mailscanner?

In my case if I do (as root):

cd /opt/MailScanner/bin
./MailScanner /opt/MailScanner/etc/MailScanner.conf

then mailscanner still loops up.  check_mailscanner and SMF scripts are
not in the picture.  Only the cron method works for me.   Aaaargh.

Jeff Earickson
Colby College

More information about the MailScanner mailing list