Mailscanner not scanning all emails

Julian Field MailScanner at
Wed Sep 28 20:04:53 IST 2005

    [ The following text is in the "windows-1250" character set. ]
    [ Your display is set for the "US-ASCII" character set.  ]
    [ Some characters may be displayed incorrectly. ]

Hash: SHA1

That is not the correct solution, but a slightly nasty hack workaround. 
It won't last, however, your system will rewrite all the soft links you 
have put in and remove them again. What you need to do is:
    1. Add the line "/usr/local/lib" to /etc/
    2. Run the "ldconfig" command.
That's what the latest version of my install-Clam-SA.tar.gz installation 

I would advise you remove the links you have added and do steps 1 and 2 
above. You may well find your links will disappear when you run 
ldconfig, which is run every time you update any RPM containing shared 
library (*.so) files.

Tony Spencer wrote:

>I still got the same problems with the newer version.
>However I've solved it now.
>Looking at the error:
>Can't load '/tmp/Mail-ClamAV-0.17/blib/arch/auto/Mail/ClamAV/' for
>module Mail::ClamAV: cannot open shared object file: No such
>file or directory at
>/usr/lib/perl5/5.8.5/i386-linux-thread-multi/ line 230.
>When doing a make test.
>I did a locate on and found it was installed in
>/usr/local/lib so I added the following symlinks:
>ln -s /usr/local/lib/ /usr/lib/
>ln -s /usr/local/lib/ /usr/lib/
>Did a make test again and got no errors.
>Maillog now shows no errors when virus scanning.
>Thanks for your help.
>-----Original Message-----
>From: MailScanner mailing list [mailto:MAILSCANNER at JISCMAIL.AC.UK] On Behalf
>Of Julian Field
>Sent: 28 September 2005 13:40
>Subject: Re: Mailscanner not scanning all emails
>Download the latest version of my install-Clam-SA.tar.gz and try  
>again, I have added some more intelligence to it in the last day or  
>so. It will now set up your so that the module build process  
>can find the ClamAV library, without you having to edit any files by  
>On 28 Sep 2005, at 12:43, Tony Spencer wrote:
>>Just in case I did something wrong or missed something I re- 
>>installed using
>>install-Clam-SA.tar.gz again, but found the following errors:
>>Finished Build Compile Stage
>>Manifying blib/man3/Mail::ClamAV.3pm
>>PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e"
>>"test_harness(0, 'blib/lib', 'blib/arch')" t/*.t
>>t/Mail-ClamAV....#     Failed test (t/Mail-ClamAV.t at line 9)
>>#     Tried to use 'Mail::ClamAV'.
>>#     Error:  Had problems bootstrapping Inline module 'Mail::ClamAV'
>># Can't load '/tmp/Mail-ClamAV-0.17/blib/arch/auto/Mail/ClamAV/ 
>>for module Mail::ClamAV: cannot open shared object  
>>file: No
>>such file or directory at
>>/usr/lib/perl5/5.8.5/i386-linux-thread-multi/ line 230.
>>#  at /usr/lib/perl5/site_perl/5.8.5/ line 500

- -- 
Julian Field
Buy the MailScanner book at
Professional Support Services at
MailScanner thanks transtec Computers for their support

PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654

Version: PGP Desktop 9.0.2 (Build 2424)


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the Wiki ( and
the archives (

Support MailScanner development - buy the book off the website!

More information about the MailScanner mailing list