strange glitch results in lost mail

Chris Yuzik chris at FRACTALWEB.COM
Mon Jul 14 21:50:02 IST 2003

Hi Evert,

Everything in my MailScanner.conf file looks ok from what I can tell. MTA and Sendmail are as you show, and sendmail is in /usr/bin/sendmail.

I haven't noticed anything particularly strange in the /var/log/maillog file...but I'm not sure what I'm supposed to look for either. Any hints?

I have added a crontab for /usr/lib/opcenter/virtualhosting/MailQueueCleaner and set it to run every 5 minutes. Not sure if this will help anything or not. I read somewhere that it might help, but certainly won't hurt anything.

Where exactly do you whitelist the internal domains? Is that in "/etc/MailScanner/spam.whitelist.rules"? I don't have this file on my system and am not sure what format to use. Could you give me a couple of examples, or point me to the right place in the docs for this?

Chris Yuzik

  ----- Original Message ----- 
  From: Evert Ford 
  Sent: Monday, July 14, 2003 11:36 AM
  Subject: Re: strange glitch results in lost mail

  since you aren't having any mail delivery problems when you start sendmail outside of MailScanner, I'd suggest looking at your whitelist rules and blacklist rules, and next I'd suggest looking for a configuration error in MailScanner.conf.  I had a similar problem until I whitelisted the internal domains I manage.

  in MailScanner.conf,  look at the following settings(just for starters):
  MTA = sendmail
  Sendmail = /usr/sbin/sendmail
  if you are using a standard install path on Redhat 7.3 for sendmail

  also, are you seeing any errors in your maillog on the e-mails that aren'd delivered?

  Evert Ford
  Information Analyst
  Westone Laboratories
    -----Original Message-----
    From: MailScanner mailing list [mailto:MAILSCANNER at JISCMAIL.AC.UK]On Behalf Of Chris Yuzik
    Sent: Monday, July 14, 2003 11:54 AM
    Subject: strange glitch results in lost mail

    Hi everyone,

    I have SpamAssassin and MailScanner running on my RedHat 7.3 machine. The server is running Ensim WEBppliance PRO 3.5.10. The server hosts about a dozen domains. I run sendmail and procmail. Almost everything works great. Almost.

    Mail from the outside world works as expected, gets scanned and scored and so forth. I've got SA's threshold set to 5 and am running DCC and the two days I tested it over the weekend, it correctly identified 99%+ of spam.

    My big problem is that sometimes mail from within the server never arrives...never bounces...just goes to a black hole.

    I'll list some examples so it makes more sense:

    1) let's pretend that and are hosted on my server. is not hosted on my server.
    2) steve at and john at can both sent to and receive email from susan at just fine. dave at and scott at can also sent to and receive email from susan at to. Internal to the outside world works.
    3) steve at can not email john at and vice-versa. Internal to internal is not working.
    4) it gets stranger. dave at can send email to scott at, but not the other way around. If scott replies to dave's message, then dave never gets the reply.

    As I said before, the message doesn't bounce or just goes into a black hole and is never seen again.

    When I installed MailScanner, the documentation said I was supposed to do the following (which is what I did):
    1) "service sendmail stop"
    2) "service MailScanner start"

    In an attempt to troubleshoot the problem, I tried the following:
    1) "service MailScanner stop"
    2) "service sendmail start"
    3) "service MailScanner start"

    Now everyone can email everyone else: internal<-> internal and internal<->external just fine. Unfortunately, now nothing gets processed through spamassassin.

    How do I go about fixing this?

    Please help.

    Chris Yuzik
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list