bigevil usage... confused

Julian Field mailscanner at
Sat Dec 20 11:59:22 GMT 2003

At 03:09 20/12/2003, you wrote:
>    I've been following the "" thread...  I
>downloaded it and put it into /etc/mail/spamassassin,
>then did
>spamassassin -D -p /opt/MailScanner/etc/spam.assassin.prefs.conf --lint
>and saw:
>debug: using "/opt/perl5/share/spamassassin" for default rules dir
>debug: using "/etc/opt/mail/spamassassin" for site rules dir
>debug: using "/home/admin/jaearick/.spamassassin" for user state dir
>debug: using "/opt/MailScanner/etc/spam.assassin.prefs.conf" for user
>prefs file
>with *no* reference to anywhere in the output.
>Hmmm...  I looked in /etc/opt/mail/spamassassin and found another
> file.  So I blew away this directory and made a symlink for
>this dir pointing to /etc/mail/spamassassin.  This directory contains
>a symlink for, which points to
>Tried the lint run again, still no reference to in the output.
>Should I see one?  What have I snarled up here?  How to see if bigevil
>is getting used (no references to BigEvilList in the SA syslogging
>either).  Help.

Never forget that Unix filesystems log the time each file was last accessed.
So if you wait a couple of minutes, run your lint command, and then do
ls -lu /etc/mail/spamassassin
then it will print the "last used" time instead of the last modification
time. If the datestamp is now and not a couple of minutes ago, then the
file has been read by something.

Very simple technique, but occasionally extremely useful.
Julian Field
Professional Support Services at
MailScanner thanks transtec Computers for their support
PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654

More information about the MailScanner mailing list