bigevil usage... confused

Jeff A. Earickson jaearick at COLBY.EDU
Sat Dec 20 14:16:55 GMT 2003

   "ls -lu" shows that /etc/mail/spamassassin/ (perms = 644)
isn't being used, even though the symlink in /etc/mail/spamassassin
(pointing to /opt/MailScanner/etc/spam.assassin.prefs.conf) is.  The
times differ substantially.  But if I run the lint command (below),
then both and have their times updated, even though
the lint output make no explicit mention of  Still no
references to bigevil in the syslog for SA.  Running SA 2.61;  now I'm
very confused.  Maybe I missed some incantation when I built/installed 2.61.
Or maybe I have to refer to somehow in spam.assassin.prefs.conf.
Any more ideas?


On Sat, 20 Dec 2003, Julian Field wrote:

> Date: Sat, 20 Dec 2003 11:59:22 +0000
> From: Julian Field <mailscanner at ECS.SOTON.AC.UK>
> Reply-To: MailScanner mailing list <MAILSCANNER at JISCMAIL.AC.UK>
> Subject: Re: bigevil usage... confused
> At 03:09 20/12/2003, you wrote:
> >Gang,
> >    I've been following the "" thread...  I
> >downloaded it and put it into /etc/mail/spamassassin,
> >then did
> >
> >spamassassin -D -p /opt/MailScanner/etc/spam.assassin.prefs.conf --lint
> >
> >and saw:
> >
> >debug: using "/opt/perl5/share/spamassassin" for default rules dir
> >debug: using "/etc/opt/mail/spamassassin" for site rules dir
> >debug: using "/home/admin/jaearick/.spamassassin" for user state dir
> >debug: using "/opt/MailScanner/etc/spam.assassin.prefs.conf" for user
> >prefs file
> >
> >with *no* reference to anywhere in the output.
> >
> >Hmmm...  I looked in /etc/opt/mail/spamassassin and found another
> > file.  So I blew away this directory and made a symlink for
> >this dir pointing to /etc/mail/spamassassin.  This directory contains
> >a symlink for, which points to
> >/opt/MailScanner/etc/spam.assassin.prefs.conf
> >
> >Tried the lint run again, still no reference to in the output.
> >Should I see one?  What have I snarled up here?  How to see if bigevil
> >is getting used (no references to BigEvilList in the SA syslogging
> >either).  Help.
> Never forget that Unix filesystems log the time each file was last accessed.
> So if you wait a couple of minutes, run your lint command, and then do
> ls -lu /etc/mail/spamassassin
> then it will print the "last used" time instead of the last modification
> time. If the datestamp is now and not a couple of minutes ago, then the
> file has been read by something.
> Very simple technique, but occasionally extremely useful.
> --
> Julian Field
> Professional Support Services at
> MailScanner thanks transtec Computers for their support
> PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654

More information about the MailScanner mailing list