Sophos sweep update problem

Julian Field mailscanner at
Fri Aug 16 20:41:26 IST 2002

At 18:14 16/08/2002, you wrote:
>I recently updated my Sophos from v359 to v360 using the Mailscanner
>Sophos.install script (on Redhat 7.2 system using 3.22-12 rpm). In the
>past this script has worked well, However, in updating to v360, sweep no
>longer worked as it came back with an "Error initialising detection
>engine [0x80040222]" message.

I have just upgraded my test server to v360 using Sophos.install and it
works just fine. I have also just tried it as well on a Solaris SPARC
system, and that worked fine too.

So I can't reproduce the problem.
On an apparently broken system, what happens if you do
         cd /opt/sophos
         bin/sophoswrapper .
         cd /usr/local/Sophos
         bin/sophoswrapper .
depending of course on where you have it installed. It should list a load
of IDE files and then say something about the number of file processed.

>  I called Sophos tech support and they said
>they have discussed this problem with the Mailscanner folks (I presume

They have done no such thing. I would be interested to see evidence of this
I haven't heard anything from Sophos at all since they launched their email
gateway program.
I hate it when people lie :-(

>  In the end, the solution was to run the script in
>the sav-install directory to fix the problem. According to the Sophos
>tech, Sophos.install does not transfer all the lib files from
>sav-install (sorry just paraphrasing so could be incorrect
>interpretation on my part) thus the need to run afterwards.

Interesting, as Sophos.install runs to do most of the work!

>Can the Sophos.install script be adjusted to fix this problem?

Not until I can find out what is going wrong for some people.

Please can someone try to catch a system doing this, and dump the whole of
into a tar file and mail it to me so I can see what's happened.
Julian Field                Teaching Systems Manager
jkf at         Dept. of Electronics & Computer Science
Tel. 023 8059 2817          University of Southampton
                             Southampton SO17 1BJ

More information about the MailScanner mailing list