mailscanner not functions correctly

Scott Farrell sfarrell at ICCONSULTING.COM.AU
Thu Nov 8 10:39:59 GMT 2001

Tell us more about your sendmail config. Are you listening to what port?
are you delivering local, or routing on?

I would first suggest running sendmail only, without mailscanner to see if
your machine/configuration is reliable.

Here is my output for you to compare :

ps -ef | grep sendmail
root      1715     1  0 20:06 ?        00:00:00 sendmail: accepting
root      1718     1  0 20:06 ?        00:00:00 /usr/sbin/sendmail -q15m
root      1836  1296  0 20:38 pts/0    00:00:00 grep sendmail

netstat -anp|grep ":25"
tcp        0      0*               LISTEN
1715/sendmail: acce

Scott Farrell
ic Consulting - the people that make eBusiness happen.
We offer e-business consulting and perform services. We deliver high impact
consulting, and fast turn around projects for our clients.
Ask us about Web Content Management,  Web Self Service, or working closer
with your customers or suppliers.

0412 927 156,   02 9411 3622  mailto:sfarrell at

                    Boris Skoblo
                    <borsk at techunix.TECHN        To:     MAILSCANNER at JISCMAIL.AC.UK
                    ION.AC.IL>                   cc:
                    Sent by: MailScanner         Subject:     mailscanner not functions correctly
                    mailing list
                    <MAILSCANNER at JISCMAIL

                    08/11/01 08:00 PM
                    Please respond to
                    MailScanner mailing

Hi All,

I could once at once after installation start mailscanner and send the
message containing test file. I have received correct response of
the program both warning messages to the sender and receiver. After that I
tried install the perl module net:: ftp, as for me was not worked
script /mcafee/autoupdate. Also I still rebooted the server.

Since then I do not see that mailscanner functions correctly. I try to send
the same test file and I receive it as not of past any anti-virus
processing. To what I have paid attention that when I run mailscanner:

[ root at host /root]# /etc/rc.d/init.d/mailscanner start
Starting MailScanner:
[ root at host /root]# ps -ef | grep sendmail
root 3180 1 0 10:41? 00:00:00 /usr/sbin/sendmail -bd -ODeliver
root 3182 1 0 10:41? 00:00:00 /usr/sbin/sendmail -q15m

But when in some minutes I again issue the command:
  [root at host /root]# ps -ef | grep sendmail,

I receive only:
   /usr/sbin/sendmail -q15m.

Whether I do not know has this ratio to my problem or and be owes

How in general to carry out correctly diagnostics of my fault?

More information about the MailScanner mailing list