MailScanner-5.4.5-3 ms-configure fails when building SpamAssassin

Wolfgang Baudler wbaudler at
Tue May 9 19:50:01 UTC 2023

When I run "/usr/sbin/ms-configure --update" after installing the latest
MailScanner-5.4.5-3.rhel.noarch.rpm (this is on a RHEL7.9 system, fully
patched), the ms-configure hangs for a while trying to build and test
Mail-SpamAssassin-4.000000 and then fails with this error:

Building and testing Mail-SpamAssassin-4.000000 ... FAIL
! Timed out (> 1800s). Use --verbose to retry.

When I run a strace on one of the perl processes during the "hang" period,
I get these repeated syscalls:

select(8, [3 5], NULL, NULL, NULL)      = 1 (in [5])
read(5, "spam_pid not found: Sleeping 7 -"..., 65536) = 44
write(2, "spam_pid not found: Sleeping 7 -"..., 44) = 44

Looks like it is trying to start and test spamd, but fails for some reason.

Any insights why this might be happening? Thanks.

seems to mention the same issue on an Ubuntu system

More information about the MailScanner mailing list