[spam] Re: Installation error now that spamassasin 4.0.0 is available

Pramod Daya pramod at mindspring.co.za
Tue Dec 19 21:50:07 UTC 2023


Has there been any update on getting Spamassassin 4.00000 to install with Mailscanner 5.4.5 ?   I've tried on Almalinux 8, and Almalinux 9, and Rocky 9.3 on Linode and on Hyper-V, and it just hangs when it gets to the point of "Building and testing Mail-Spamassassin-4.000000", and then times out. 

I also tried doing an installation of spamassassin from CPAN but that doesn't work either.   I'm at my wits end.   Some guidance on how to install Mailscanner would be very gratefully accepted. 

Thank you!

-----Original Message-----
From: MailScanner <mailscanner-bounces+pramod=mindspring.co.za at lists.mailscanner.info> On Behalf Of mailscanner at barendse.to
Sent: Monday, June 5, 2023 1:38 PM
To: Shawn Iverson via MailScanner <mailscanner at lists.mailscanner.info>
Subject: [spam] Re: Installation error now that spamassasin 4.0.0 is available

On Sat, 31 Dec 2022, Shawn Iverson via MailScanner wrote:

> On 12/29/22 20:17, Rick Gutierrez wrote:
>> El mié, 21 dic 2022 a las 13:04, Andrew Pearce 
>> (<andrew at andew.org.uk>)
> escribió:
>>> Hi
>>> I got my installation to work with running the following command as 
>>> it looks like Zlib wasnt fully updated
>>>    cpanm --uninstall IO::Compress::Zlib::Extra
>> thank Andrew .
> I'm going to rework the MailScanner ms-configure for RHEL derivatives 
> to prefer rpm installs of the latest SA.  Hopefully this will help 
> alleviate some of these issues for folks....

I'm on ubuntu but also install SpamAssassin and preferably as many other packages as possible from apt, I hope to avoid as much as possible that a security update gets released without it getting installed because I didn't notice it. I found a lot of perl modules in apt already but couldn't get all to install

More information about the MailScanner mailing list