MailScanner Lint Error

L.P.H. van Belle belle at
Tue Aug 11 07:10:16 UTC 2020

Hai Paul, 
I've had a better look here on my Debian Buster system.
If i compair my MailScanner --lint output. im missing some part in yours.

Checking version numbers...
Version number in MailScanner.conf (5.3.3) is correct.
Your envelope_sender_header in spamassassin.conf is correct.
MailScanner setting GID to  (113)        <<<<<<<
MailScanner setting UID to  (108)        <<<<<<<

Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache

im running it all as user postfix  with these as member in mtagroup. 


check which user your MTA is running, and setup the new config. 

Run As User = YourServiceUsers
Run As Group = YourServiceUsers
so im still thinking your rights are off somewhere. 

If you ever changed the MailScanner.conf, revert it back to defaults and add you settings in a seperated files as shown.
i would suggest, backup the old config file. 
install the new one dont change it. 
make of copy of the new one (clean on)  and add one in /etc/MailScanner/conf.d/01-mycompanysettings.conf   and only change whats needed there
On the "CPAN" upgrade of SpamAssassin. 
I then do hope you removed the "packages" or set it to hold, because what if .... you now get an upgrade of SpamAssassin packages..
I dont know Centos that good. 
Review you MailScanner.conf settings but start with a clean file. 
Remove the updated spamassassin and use the system packaged one. 
but since your using Centos-6 well, upgrade it. yes, you are "maintained" but that stops in 3,5 months. 
Dont wait it out, this is the chance to start fresh, but thats my advice. 
See how far you get. 

Can you also ( on a next attempt to make it run) post a output of the mail.log.
Dont neeed it all, only the MailScanner/Spamassassin parts 
So far, 
Sorry for later reply, my previous we i think 15m before i feel a sleep. ;-) 

Van: MailScanner [ at] Namens Paul Scott
Verzonden: maandag 10 augustus 2020 21:08
Aan: MailScanner Discussion
Onderwerp: MailScanner Lint Error


Hello MailScanner folks and friends:


I continue to hammer away at trying to get MailScanner working again.  I managed to get the install to run without error, but I still do not see MailScanner actively processing any SPAM at all in the “maillog” log file.  It only shows its startup messages, and that’s it.  The process ID remains running, but MailScanner is effectively dead (doesn’t do any work).  I also did successfully use CPAN to upgrade Spam Assassin to the very latest version, just now.


[root at fs9 log]# spamassassin -V

SpamAssassin version 3.4.4

  running on Perl version 5.10.1

[root at fs9 log]#



After that, I tried MailScanner –lint, and had some issues, which I fixed, until I now have this result:


[root at fs9 ~]# MailScanner --lint

Trying to setlogsock(unix)


Reading configuration file /etc/MailScanner/MailScanner.conf

Reading configuration file /etc/MailScanner/conf.d/README

Read 1500 hostnames from the phishing whitelist

Read 7949 hostnames from the phishing blacklists


Checking version numbers...

Version number in MailScanner.conf (5.3.3) is correct.


Your envelope_sender_header in spamassassin.conf is correct.


Checking for SpamAssassin errors (if you use it)...

Using SpamAssassin results cache

Connected to SpamAssassin cache database

config: registryboundaries: no tlds defined, need to run sa-update    <<<<  this one is one i am missing ..  i get : internal error, python traceback seen in response
SpamAssassin reported no errors.

Auto: Found virus scanners: clamd 

Using locktype = flock

MailScanner.conf says "Virus Scanners = auto"

Found these virus scanners installed: clamd


Filename Checks: Windows/DOS Executable (1

Other Checks: Found 1 problems

Virus and Content Scanning: Starting

Clamd::INFECTED:: Win.Test.EICAR_HDB-1 :: ./1/

Virus Scanning: Clamd found 2 infections

Infected message 1 came from

Virus Scanning: Found 2 viruses


Virus Scanner test reports:

Clamd said " was infected: Win.Test.EICAR_HDB-1"


If any of your virus scanners (clamd)

are not listed there, you should check that they are installed correctly

and that MailScanner is finding them correctly via its virus.scanners.conf.


I don’t know what this error means, or how to fix it—I did run “sa-update”, and it did not fix it:

config: registryboundaries: no tlds defined, need to run sa-update


Can you please let me know how to fix this?



Also, of interest, I read in the spamassassin.conf that there is a Processing.db, that is in the /var/spool/MailScanner/incoming folder, and to clear it, you delete it, and it should be recreated when MailScanner is restarted, it will be recreated.  I tried that, but it did NOT get recreated, not sure why.  Any ideas?


The bottom line here is that MailScanner is not doing what it should be doing, and that is scanning incoming mail.  I am having a great deal of trouble figure this out.  Please help.  Thank you very much!




Paul Scott
Engineer, Eden USA, Incorporated 

866.501.3336 | 951.505.6967 | sales at 




-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the MailScanner mailing list