constant restart

Rick Gutierrez xserverlinux at
Wed Aug 21 11:48:59 UTC 2019

El mar., 20 ago. 2019 a las 23:31, Thom van der Boon (<thom at>) escribió:
> Rick,
> Did you disable selinux on CentOS (and reboot)?
> What is the permission and filetype of the clamd.sock : ls -lah /var/run/clamd.scan/clamd.sock
> clamd can be running, but at what port is it listening? netstat -ln
> Disable your firewall temporary, restart MailScanner and run Mailscanner --lint
> Met vriendelijke groet, Best regards,

yes reboot the server , ls -lah /var/run/clamd.scan/clamd.sock
srw-rw-rw- 1 clamscan mtagroup 0 Aug 21 05:42 /var/run/clamd.scan/clamd.sock

clamd is runnning on the port 3310

[root at escm ~]# netstat -ln
Active Internet connections (only servers)
Proto Recv-Q Send-Q Local Address           Foreign Address         State
tcp        0      0    *               LISTEN
tcp        0      0   *               LISTEN
tcp        0      0*               LISTEN
tcp        0      0 *               LISTEN
tcp        0      0    *               LISTEN

disabled my firewall and run test debug of MailScanner

 MailScanner --debug --lint
Trying to setlogsock(unix)

Reading configuration file /etc/MailScanner/MailScanner.conf
Reading configuration file /etc/MailScanner/conf.d/README
Read 1500 hostnames from the phishing whitelist
Read 6730 hostnames from the phishing blacklists
Config: calling custom init function SQLBlacklist
Config: calling custom init function MailWatchLogging
Config: calling custom init function SQLWhitelist

Checking version numbers...
Version number in MailScanner.conf (5.1.3) is correct.

Your envelope_sender_header in spamassassin.conf is correct.
MailScanner setting UID to  (89)

Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache
Connected to SpamAssassin cache database
SpamAssassin reported no errors.
Connected to Processing Attempts Database
Created Processing Attempts Database successfully
There are 502 messages in the Processing Attempts Database
Using locktype = posix
MailScanner.conf says "Virus Scanners = clamd"
Found these virus scanners installed: clamav
Filename Checks: Windows/DOS Executable (1
Other Checks: Found 1 problems
Virus and Content Scanning: Starting
Cannot find Socket (/var/run/clamd.scan/clamd.sock) Exiting! at
/usr/share/MailScanner/perl/MailScanner/ line 2159.
Virus Scanning: No virus scanners worked, so message batch will be
tried again at /usr/share/MailScanner/perl/MailScanner/
line 506.

thanks for the support guys


More information about the MailScanner mailing list