File(name|type) rules - was hijacked: "Allow Script Tags" affects attachments?

Mark Sapiro mark at
Tue Feb 7 21:28:55 UTC 2017

On 02/07/2017 01:16 PM, Paul Scott wrote:
> Basically, turning everything off.  However, I did find another issue, and that is that the standard way we use to restart MailScanner has changed.  I tried this:
> [root at mail MailScanner]#service mailscanner restart
> Which appeared to restart the MailScanner correctly, but processing no longer worked.  I had to reboot the machine, which caused a major issue, and had to drive 100+ miles to the server room to manually start it up again.
> What is the recommended way of getting MailScanner properly restarted, after making configuration file changes?

It is what you did. Namely,

service mailscanner restart

Why it didn't work, I can't say. There have been changes from
MailScanner V4 to V5 in that restarting, starting and stopping the MTA
is decoupled from restarting, starting and stopping MailScanner.

In order to say more, I'd need to know what your MTA is and the contents
of /etc/init.d/mailscanner.

Also, the contents of the system mail log from around the time you did
the service mailscanner restart might have clues.

Mark Sapiro <mark at>        The highway is for gamblers,
San Francisco Bay Area, California    better use your sense - B. Dylan

More information about the MailScanner mailing list