Infinite loop.

Ken ravenpi at
Fri Sep 7 17:13:32 IST 2012

Well!  I installed Baruwa -- don't even really know what it does, but it
gave me a functioning package for MailScanner, so that was a plus.  A
minus, however, was the fact that MailScanner was pegging the CPU at 100%.
 A strace turned up this:

write(2, "Use of uninitialized value $fam_listen in numeric ne (!=) at
/usr/share/perl5/IO/Socket/ line 182.\n", 107) = 107

Googling showed that others had had this issue with Spam Assassin and/or
Amavis, and had fixed it by disabling IPV6.  Unfortunately, that appeared
not to work in this case.  So I did A Bad Thing that will no doubt come and
bite me some day.  In /usr/share/perl5/IO/Socket/, I tweaked as

#       next if $fam_listen != $family;

(My reasoning being that if it's undefined, it's also inequal, so just go
and do it.)  And lo!  My mail, she now gets checked.  However, I have a
couple of issues with this:
- This is a crazy bad thing to do on a package-managed system.  (Thoughts
of "chattr +i /usr/share/perl5/IO/Socket/" float through my head...)
- What if I wanted to use IPv6... which I do?
- Have I broken anything that's not IPv6 by ignoring that one line in

If anyone's got any ideas or insights they'd like to share, I'm all ears.



On Fri, Sep 7, 2012 at 9:51 AM, Ken <ravenpi at> wrote:

> Hi, all.  I recently "upgraded" my Ubuntu server to Precise, and lo!
>  Wasn't I surprised when I realized there was no MailScanner any more.  I
> tried following the directions on the MailScanner site for doing an install
> from Debian sources, but that appears to be outdated and no longer valid.
>  So I installed from source, and created a link from my old
> /etc/MailScanner directory to /opt/MailScanner/etc.  And it *almost* works.
>  But it doesn't.  I get this:
> Sep  7 09:06:37 beacon MailScanner[480]: MailScanner E-Mail Virus Scanner
> version 4.84.5 starting...
> Sep  7 09:06:37 beacon MailScanner[480]: Could not read Custom Functions
> directory /etc/MailScanner/CustomFunctions
> Sep  7 09:06:37 beacon MailScanner[480]: Reading configuration file
> /opt/MailScanner/etc/MailScanner.conf
> Sep  7 09:06:37 beacon MailScanner[480]: Read 817 hostnames from the
> phishing whitelist
> Sep  7 09:06:38 beacon MailScanner[480]: Read 5141 hostnames from the
> phishing blacklists
> Sep  7 09:06:39 beacon MailScanner[480]: Using SpamAssassin results cache
> Sep  7 09:06:39 beacon MailScanner[480]: Connected to SpamAssassin cache
> database
> Sep  7 09:06:39 beacon MailScanner[480]: Enabling SpamAssassin
> auto-whitelist functionality...
> Sep  7 09:06:43 beacon MailScanner: waiting for children to die: Process
> did not exit cleanly, returned 255 with signal 0
> Rinse and repeat.
> Eventually, my mail *does* seem to have made it through, except that I'm
> no longer filtering for spam:
> X--MailScanner-SpamCheck: notspam, spamassassin (sadisabled)
> Which is almost worse than not getting any at all.  (One of my e-mail
> addresses has been around for a l-o-n-g time, and is probably on every damn
> spam list there is.)
> Suggestions on how to enable more debugging (Google came up surprisingly
> empty), or other things to look at/tweak?
> Thanks,
> -Ken
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list