Bayes Scoring

M A Young m.a.young at
Thu Mar 15 23:09:04 GMT 2012

On Wed, 14 Mar 2012, Pramod Daya wrote:

> I have a functioning installation of mailscanner 4.79 on Centos 5.7 in which
> the Bayes scoring does not appear to be working, or at least, I do not see
> the bayes scoring tokens appearing in the message headers.  I have trained
> spamassassin  by dropping spam into an IMAP mailbox (with about 6 000 spam
> and a few hundred ham messages), and  running sa-learn as user “postfix”.

Two thoughts occur. You could have got the sa-learn options wrong, and 
thus submitted one huge spammy message rather than 6000 smaller messages 
(I think you need the --mbox flag for sa-learn).

Also your spamassassin configuration could be missing. I hit this in a 
non-obvious way after deleting spamassassin files under 
/var/lib/spamassassin for a previous version after the file system had 
filled up. Later I noticed that spamassassin was letting spam through and 
MailScanner was only recording the use of some local rules I had added, 
but spamassassin worked fine when I ran it directly. I eventually traced 
the problem to some spamassassin perl files that had been left from an 
older version in a different part of the perl search path to the current 
version. MailScanner was finding the old files and trying to use the 
older spamassassin configuration files I had deleted, but spamassassin was 
using the current files when run directly.

Also, as with any CentOS problem of things not working as expected, you 
can try again with selinux off if it is enabled (eg. run setenforce 0 
beforehand), as selinux is good at getting in the way if you are doing 
things in ways it doesn't quite expect.

 	Michael Young

More information about the MailScanner mailing list