Spamassassin woes...

Martin Hepworth maxsec at
Tue Mar 15 06:23:49 GMT 2011


Ms doesn't use the binaries but the perl api as you prob know. Have
you done a sa-update as the 3.3 releases have no rules by default and
you have to download them. I'd check the binaries aren't elsewhere.


On Tuesday, 15 March 2011, Kevin Miller <Kevin_Miller at> wrote:
> This morning I tried to update my spamassasin and it seems to be only half baked.
> I'm running on SUSE Linux Enterprise Server 11 SP1.
> I was using the distro rpm, but it was just version 2.5.x.  I figured I outta upgrade to 3.3.1, courtesy of Julian's package.
> I uninstalled the SLES spamassassin rpms then downloaded the Install-Clam-SA-latest.tar.gz package from and ran the script.
> See for gory details.
> When I ran it, it asked if I wanted to install clamav.  I said no - line 31.  It seems to have tried to install clamav anyway.
> Around line 119 it blew up.
> Re line 121 - make is installed.  The build directory referenced on line 124 does not exist.  I don't know whether the process deleted it or if it never existed.
> The script proceeds to go about installing spamassassin but at 452 there's a funny error.  Not sure it's critical.
> When I start MailScanner it seems to find spamassassin.  However it doesn't all seem to be there.  I used to have spamassassin, spamc and spamd in /usr/bin.  They're now gone.
> Sa-learn, sa-compile, and sa-update are also MIA.
> Does the mailscanner package not install the whole enchalada?
> As I mentioned, when running MailScanner, the messages are examined by spamassassin, but the system is a bit crippled with key binaries not present.
> Thanks.
> ...Kevin
> --
> Kevin Miller                Registered Linux User No: 307357
> CBJ MIS Dept.               Network Systems Admin., Mail Admin.
> 155 South Seward Street     ph: (907) 586-0242
> Juneau, Alaska 99801        fax: (907 586-4500

Martin Hepworth
Oxford, UK

More information about the MailScanner mailing list