MailScanner won't release email

Dave Higgins dave.higgins at
Tue Jul 26 17:05:04 IST 2011

I solved the problem.  There appears to be a problem with permissions. 
In the startup script, I had to add a -c${user} to the line:

start-stop-daemon --start --quiet --nicelevel $run_nice -c${user} --exec 

There are 2 start-stop-daemon lines, this (in my configuration) is the 
second line.

On 07/26/2011 09:51 AM, Dave Higgins wrote:
> My power went out and my machine restarted but MailScanner was damaged
> in the process. My configuration has worked for quite some time and
> haven't had any troubles. Email will not be delivered as it should.
> 'postqueue -p' shows the QueueID with an ! after each message. I can do
> a postsuper -H $ID and release a message, but that's a bit of a pain.
> When I run MailScanner --debug as user postfix, I get no errors.
> When I run MailScanner --lint, other than ClamAV being out of date,
> nothing gives me any indication of problems.
> When I do a '/etc/init.d/mailscanner start' to start the process, as it
> would at startup, it does not work.
> When I 'su - postfix' and then do 'MailScanner --debug', it works.
> I'm at a loss at this point.

Dave Higgins
Littleton, Colorado
dave.higgins at
See my photos at
Sell by date stamped on bottom.

No virii here...

More information about the MailScanner mailing list