Spamassassin Not working

Brian Cullins brian at
Fri Mar 19 21:19:51 GMT 2010

I reverted to 3.2.5 and it works now.


From: mailscanner-bounces at
[mailto:mailscanner-bounces at] On Behalf Of Drew
Sent: Friday, March 19, 2010 2:49 AM
To: MailScanner discussion
Subject: Re: Spamassassin Not working



On 18 Mar 2010, at 20:04, Brian Cullins wrote:

After upgrading to Spamassassin 3.3.0, it is now broken. MailScanner scans
mail and delivers it as if the "Use Spamassassin" pref is set to "No". I
have reverted to the older version of SA and even installed the latest beta
of MS and it is still broken...any ideas?


SA 3.3 comes with no rules in it's installation package. Have you run
sa-update yet? If not you will have no rules to score mail against, which
will cause the effect you have seen. 


The other one you need to also check is the SpamAssassin Local State Dir =
line in MailScanner.conf has the correct path to the rules that have been
downloaded. In FreeBSD this is /var/db/spamassassin but I would think in
most variations of Linux it's going to be /var/lib/spamassassin


I used to get away with this line being one directory higher but I think the
structure changed slightly with the latest SA (Or it possibly never worked
properly ;-) ).


Hope this helps



This message has been scanned for viruses and 
dangerous content by  <> MailScanner, and is 
believed to be clean. 

In line with our policy, this message has been scanned for viruses and
dangerous content.
Our email policy can be found at

Trunk Networks Limited is registered in Scotland with registration number:
Registered Office 55-57 West High Street Inverurie AB51 3QQ 

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list