Upgrade not delivering emails

Julian Field MailScanner at ecs.soton.ac.uk
Tue Apr 27 08:51:27 IST 2010

I would strongly advise you ditch clamavmodule and switch to clamd instead.
Remove all trace of ClamAV from /usr/local, then install the ClamAV RPMs 
from packages.sw.be (an RPMforge site). Then ensure the socket filenames 
are the same in /etc/clamd.conf and /etc/MailScanner/MailScanner.conf 
and set "Virus Scanners = clamd". It will be faster and use a lot less 

I'm considering removing the clamavmodule support altogether, it just 
isn't worth it being there any more.


On 27/04/2010 02:49, Tony Arcus wrote:
> This is my first post, so a bit of background.
> Had a couple of emails servers stop sending emails, they backed up in 
> the inbound queue.
> Did a search and saw the need to upgrade clamav.
> So upgrade the servers Version 4.79.11-1 & ClamAV 0.95.3 and 
> SpamAssassin 3.3.0
> Still a few problems
> This morning saw the new ClamAV 0.96 and SpamAssassin 3.3.0
> and now almost all sweet.
> One server is still not sending emails to users, but it does seem to 
> be sending some spam though from time to time.
> If I run it in debug mode nothing jumps out to me, the emails are 
> processed but end back in the inbound queue and not the user.
> Here is the --lint
> though I am getting an error here
> Trying to setlogsock(unix)
> Reading configuration file /etc/MailScanner/MailScanner.conf
> Reading configuration file /etc/MailScanner/conf.d/README
> Read 859 hostnames from the phishing whitelist
> Read 5874 hostnames from the phishing blacklists
> Config: calling custom init function SQLBlacklist
> Starting up SQL Blacklist
> Read 0 blacklist entries
> Config: calling custom init function MailWatchLogging
> Started SQL Logging child
> Config: calling custom init function SQLWhitelist
> Starting up SQL Whitelist
> Read 0 whitelist entries
> Checking version numbers...
> Version number in MailScanner.conf (4.79.11) is correct.
> Your envelope_sender_header in spam.assassin.prefs.conf is correct.
> Checking for SpamAssassin errors (if you use it)...
> Using SpamAssassin results cache
> Connected to SpamAssassin cache database
> SpamAssassin reported no errors.
> Connected to Processing Attempts Database
> Created Processing Attempts Database successfully
> There are 100 messages in the Processing Attempts Database
> Using locktype = posix
> MailScanner.conf says "Virus Scanners = clamavmodule"
> Found these virus scanners installed: clamavmodule
> =========================================================================== 
> Filename Checks: Windows/DOS Executable (1 eicar.com)
> Other Checks: Found 1 problems
> Virus and Content Scanning: Starting
> ClamAVModule::INFECTED:: Eicar-Test-Signature:: ./1/eicar.com
> Commercial scanner clamavmodule timed out! at 
> /usr/lib/MailScanner/MailScanner/S
> clamavmodule: Failed to complete, timed out at 
> /usr/lib/MailScanner/MailScanner/
> Virus Scanning: Denial Of Service attack detected! at 
> /usr/lib/MailScanner/MailS
> I do not believe that I am suffering a denial of service attack but 
> that the anti-virus is having issues,
> can anyone shed any light on this please.
> Thanks


Julian Field MEng CITP CEng
Buy the MailScanner book at www.MailScanner.info/store

Need help customising MailScanner?
Contact me!
Need help fixing or optimising your systems?
Contact me!
Need help getting you started solving new requirements from your boss?
Contact me!

PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654
Follow me at twitter.com/JulesFM and twitter.com/MailScanner

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the MailScanner mailing list