Upgrade not delivering emails

Tony Arcus tony at ai.net.nz
Tue Apr 27 02:49:25 IST 2010

This is my first post, so a bit of background.

Had a couple of emails servers stop sending emails, they backed up in  
the inbound queue.
Did a search and saw the need to upgrade clamav.
So upgrade the servers Version 4.79.11-1 & ClamAV 0.95.3 and  
SpamAssassin 3.3.0
Still a few problems
This morning saw the new ClamAV 0.96 and SpamAssassin 3.3.0
and now almost all sweet.


One server is still not sending emails to users, but it does seem to  
be sending some spam though from time to time.
If I run it in debug mode nothing jumps out to me, the emails are  
processed but end back in the inbound queue and not the user.
Here is the --lint

though I am getting an error here

Trying to setlogsock(unix)

Reading configuration file /etc/MailScanner/MailScanner.conf
Reading configuration file /etc/MailScanner/conf.d/README
Read 859 hostnames from the phishing whitelist
Read 5874 hostnames from the phishing blacklists
Config: calling custom init function SQLBlacklist
Starting up SQL Blacklist
Read 0 blacklist entries
Config: calling custom init function MailWatchLogging
Started SQL Logging child
Config: calling custom init function SQLWhitelist
Starting up SQL Whitelist
Read 0 whitelist entries

Checking version numbers...
Version number in MailScanner.conf (4.79.11) is correct.

Your envelope_sender_header in spam.assassin.prefs.conf is correct.

Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache
Connected to SpamAssassin cache database
SpamAssassin reported no errors.
Connected to Processing Attempts Database
Created Processing Attempts Database successfully
There are 100 messages in the Processing Attempts Database
Using locktype = posix
MailScanner.conf says "Virus Scanners = clamavmodule"
Found these virus scanners installed: clamavmodule
Filename Checks: Windows/DOS Executable (1 eicar.com)
Other Checks: Found 1 problems
Virus and Content Scanning: Starting
ClamAVModule::INFECTED:: Eicar-Test-Signature:: ./1/eicar.com
Commercial scanner clamavmodule timed out! at  
clamavmodule: Failed to complete, timed out at  
Virus Scanning: Denial Of Service attack detected! at  

I do not believe that I am suffering a denial of service attack but  
that the anti-virus is having issues,
can anyone shed any light on this please.


Tony Arcus
Systems and Network Engineer
Access Information Limited
PO Box 122

Phone : 06-379-6668
Phone : 04-831-1401
Email : tony at ai.net.nz
Cell  : 021-827-660

This email and any accompanying documentation may contain privileged and
confidential information.  If you are not the intended recipient, your use
of the information is strictly prohibited.

This message was sent using IMP, the Internet Messaging Program.

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the MailScanner mailing list