Got a real nightmare on my hands installing the newest

Steve Campbell campbell at
Tue Oct 13 15:40:17 IST 2009

Dimitri Yioulos wrote:
> On Monday 12 October 2009 3:53:13 pm Steve 
> Campbell wrote:
>>>> I just tried updating MS on a Centos 3 box.
>>>> Seems like a lot of the perl modules need
>>>> perl-5.8.1, while the latest perl for Centos
>>>> 3 is only 5.8.0-94, so a lot of stuff
>>>> failed, along with MS.
>>>> I started installing what was needed with
>>>> rpmbuild, but got into the dependency
>>>> circle, so I tried going back a to MS 4.72.
>>>> Now a lot of the modules were deleted by the
>>>> new stuff and I'm not sure that they weren't
>>>> just ignored in the 4.72 install.
>>>> Anyone got a suggestion for me who has done
>>>> the Centos 3 install?
>>>> Thanks
>>>> steve campbell
> I, too, am still using CentOS 3 as my mail server 
> platform, and I, too, ran into the problems you 
> describe.  I'm running the same perl version as 
> you, as well.  IIRC, I updated all of the perl 
> modules that MS uses (from Dag repository), then 
> installed MS from the RPM itself.  It worked/is 
> still working great.
> HTH.
> Dimitri

How did you get around the Perl 5.8.1 dependency of some of the modules? 
Doesn't it still complain and fail even with the non-Dag stuff? I have 
the rpmforge repo on this system. Is Dag and rpmforge still the same? 
Think I'll try your way another day.

I got my system back by running an older version upgrade, then moving 
back to the version I started with. Seems that older versions didn't 
remove things, and if the new perl module failed, it could still work 
OK, but the newer install tends to remove things first. If that hadn't 
worked, I was going to do a restore of the entire server from last week. 
I'm still a little worried I might not have something that's not just right.

Thanks for the info.


More information about the MailScanner mailing list