OT: Snertsoft roundhouse on Solaris 8

Anthony Peacock a.peacock at chime.ucl.ac.uk
Thu Nov 12 14:25:46 GMT 2009

Glenn Steen wrote:
> 2009/11/10 Anthony Peacock <a.peacock at chime.ucl.ac.uk>:
>> Hi Gary,
>> Thanks for your message.
>> I decided to spend a little more time looking into the problem this morning,
>> and bizzarely, it worked fine first time.  I didn't do anything differently
>> this morning compared to previous occasions, and I am at a loss to explain
>> why it is working now, and not before.
>> I'm going to leave it running (complete with truss output) for a couple of
>> hours to run my tests and then I may never need to run it on Solaris 8 again
>> (with any luck).
>> Gary Pentland wrote:
>>> # truss -wall -rall -leaf /opt/local/snertsoft/bin.....
>>> Would be the debugging option if you like strace and similar
>> I had been looking into this, hadn't found anything obvious yet.
>>> If I read this right, roundhouse works reliably on port 26, normal mta on
>>> 25....
>>> Swap the ports around and it doesn't work...  Is that correct?
>> It is not quite that simple, but that is one of the failure patterns.
>>> If that is the case I'd guess then that there is a config issue in
>>> swapping the ports around, does roundhouse run on 25 with no MTA running?
>>>  Obviously difficult to try if this is your real server but I suspect
>>> something is holding port 25 open and that is preventing roundhouse from
>>> starting.
>>> I assume that you are starting the MTA on 26 first, then roundhouse?  Try
>>> the other way around, start roundhouse first then the MTA... or simply start
>>> the MTA and then the old # netstat -an | grep LISTEN or similar to check 25
>>> is available for roundhouse.
>>> I do suspect this will turn out to be something silly/obvious....
>> Me too!
> Might actually be quite simple... Sendmail might've taken a while to
> "go away", so kept port 25 for itself, the first time around... And
> not the second;-).

Yes, this was what I was thinking.  Nothing shows up in netstat 
listening on 25.  But I am not sure this is the whole story.  I suspect 
there may be some Solaris 8 funnyness as well.  Once I have finished the 
migration I will be able to ignore Solaris 8 for ever more.

Anyway, whilst trying to debug using truss, it started to work in the 
correct configuration.  So I left it running for long enough for the 
assurance tests I wanted.  I am still not 100% certain I understand the 
full story, but I have completed the task I needed for now.

Thanks for all of the suggestions.

Anthony Peacock
Head of Research & Development, FBS Advanced IT Support Centre
CHIME, Whittington Campus
WWW:    http://www.chime.ucl.ac.uk/~rmhiajp/

More information about the MailScanner mailing list