AW: SV: Perl problems on Fedora 9 SOLVED

Julian Field MailScanner at
Wed May 6 20:51:03 IST 2009

I will happily help you out, provided I can see what the problems are, 
and if enough people are affected by the problem. I'm slightly loathed 
to spend lots of time solving packaging problems if only 3 people are 
still using Fedora 9 in the first place, I'm sure you understand :-)

*If* I get time in the next day or two to install Fedora 9 and try to do 
a clean install, I'll see what I can do and put out a beta of the next 
version of MailScanner that will work for you folks.

But no promises, I do have a day job to do as well, which is pretty busy 
right now!


On 06/05/2009 20:35, Oliver Falk wrote:
> Note:
> I've tried to bug Fedota Perl packager to update a few modules and was successfull!
> So, I wonder which packages need to be replaced by the MS!?
> There was also some thread about why not package it within the distribution..
> Well, if enough of you run Fedora... I can imagine a SIG. I can also imagine beeing the primary packager... If you want.
> And finally. I can also imagine doing this for RHEL, using EPEL...
> It's just a "Do you want this?"
> Are there other Fedora packagers (or some who want to become one) who are willing to help? Because fom time to time I tend to enjoy some holiday :-)
> Or - as an old RPM packager - shall I just try to fix broken specs and the
> Keep me posted...
> -of
> ----- Ursprüngliche Nachricht -----
> Von: Jonas Lilja<jonas.lilja at>
> Gesendet: Mittwoch, 06. Mai 2009 21:09
> An: MailScanner discussion<mailscanner at>
> Betreff: SV: Perl problems on Fedora 9 SOLVED
> Hi, I followed your suggestions and simply installed the missed perl-modules (and the perl-Pod-Simple) with yum. Now the install-script works fine.
> Thanx guys
> Jonas
> -----Ursprungligt meddelande-----
> Från: mailscanner-bounces at [mailto:mailscanner-bounces at] För Eli Wapniarski
> Skickat: den 6 maj 2009 19:14
> Till: mailscanner at
> Ämne: Re: Perl problems on Fedora 9
> Try reinstalling  perl-ExtUtils-MakeMaker and perl-devel from Fedora's update repository. That should fix things. I had the same problem on Fedora 10.
> After you've done that make a back up of /etc/Mailsacnner. Then, rpm -Uvh --force mailscanner-4.76.24-3.noarch.rpm. Then run the install script. Everything should be OK.
> Eli
> On Wednesday 06 May 2009 17:34:12 Jonas Lilja wrote:
>> Hi, I've search for Perl issues in the archive of this list but can't find any solutions regarding Fedora 9 (I've understand that there is a lot of problems with Fedora 10). Now - when I try to install or upgrade (no matter what) I get this error:
>> /usr/bin/perl "-Iblib/arch" "-Iblib/lib" "-MExtUtils::MY" -e "MY->fixin(shift)" blib/script/instmodsh
>> Can't locate Pod/ in @INC (@INC contains: blib/arch blib/lib /usr/local/lib/perl5/site_perl /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl /usr/local/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/local/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/vendor_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/vendor_perl/5.10.0 /usr/lib/perl5/vendor_perl /usr/lib/perl5/5.10.0/i386-linux-thread-multi /usr/lib/perl5/5.10.0 /usr/lib/perl5/site_perl/5.10.0/i386-linux-thread-multi /usr/lib/perl5/site_perl/5.10.0 /usr/lib/perl5/site_perl .) at /usr/lib/perl5/5.10.0/Pod/ line 35.
>> BEGIN failed--compilation aborted at /usr/lib/perl5/5.10.0/Pod/ line 35.
>> Compilation failed in require at blib/lib/ExtUtils/Command/ line 95.
>> make: *** [manifypods] Error 2
>> error: Bad exit status from /var/tmp/rpm-tmp.30068 (%build)
>> RPM build errors:
>>      Bad exit status from /var/tmp/rpm-tmp.30068 (%build)
>> Missing file /usr/src/redhat/RPMS/noarch/perl-ExtUtils-MakeMaker-6.50-2.noarch.rpm.
>> Maybe it did not build correctly?
>> ------------------------------------
>> I have tried to remove MS completely and make a fresh installation but with the same result. I've also updated Perl (yum update perl*) but MS install script seems to remove that Perl-installation and try to install its own Perl-modules. Finally, I tried to install MS with nodeps but it didn't work--
> MailScanner mailing list
> mailscanner at
> Before posting, read
> Support MailScanner development - buy the book off the website!


Julian Field MEng CITP CEng
Buy the MailScanner book at
Follow me at

MailScanner customisation, or any advanced system administration help?
Contact me at Jules at Jules.FM

PGP footprint: EE81 D763 3DB0 0BFD E1DC 7222 11F6 5947 1415 B654
PGP public key:

This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the MailScanner mailing list