New Server, same old problem

Alden Levy alden at
Sat Feb 28 21:51:49 GMT 2009

I've been running MS for a few years now, and I love it.  This list has
been a tremendous help whether I'm just lurking or have a specific

This time, it's another question: This is the second server I've switched
my MS install to, and the second time I've had a problem.  Unfortunately,
I can't find the guy who helped me the first time around. So, I was hoping
someone here would be able to help.

In any event, here are the specifics:
Until recently, I had two servers running MS (one FC3!) and one CentOS 4. 
I have now consolidated onto one server running CentOS 5.2.  All of the
servers had been running Ensim (now, Parallels Pro 10.x). However, I have
always run MS outside of Ensim.

I copied the MS directory (/etc/MailScanner) from the CentOS 4 server, and
tried to harmonize my with the one from the old server as
well.  I installed a new MS and upgraded the conf files.  The old servers
are now long gone.

Right now, I have MS 4.74.16 installed.  When I go to start it up (after
following all of the instructions and turning off sendmail), mail flows in
fine, but I cannot telnet in to the mail server, nor can I send mail.  It
seems that this would be a sendmail issue, but when I shut down MS and
start up sendmail, everything flows fine.

The only change that I can recall making from my last instance was using
clamd instead of clamav.  I tried switching back to clamav, but I still
had these issues.  I have been running sendmail with spamc/spamd and clamd
until I could get this fixed, but I don't have to tell you that this
doesn't give me the flexibility or control that running MS does.

The results of MailScanner --lint are:
Trying to setlogsock(unix)
Read 856 hostnames from the phishing whitelist
Read 4798 hostnames from the phishing blacklist
Checking version numbers...
Version number in MailScanner.conf (4.74.16) is correct.

Your envelope_sender_header in spam.assassin.prefs.conf is correct.

Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache
Connected to SpamAssassin cache database
SpamAssassin reported no errors.
I have found clamd scanners installed, and will use them all by default.
Using locktype = posix
MailScanner.conf says "Virus Scanners = auto"
Found these virus scanners installed: clamd
Filename Checks: Windows/DOS Executable (1
Other Checks: Found 1 problems
Virus and Content Scanning: Starting
Clamd::INFECTED:: Eicar-Test-Signature :: ./1/
Virus Scanning: Clamd found 2 infections
Infected message 1 came from
Virus Scanning: Found 2 viruses
Virus Scanner test reports:
Clamd said " was infected: Eicar-Test-Signature"

If any of your virus scanners (clamd)
are not listed there, you should check that they are installed correctly
and that MailScanner is finding them correctly via its virus.scanners.conf.

Likewise, spamassassin -D --lint doesn't give any errors.

MailScanner -v lists all of the required modules.  The only optional ones
I'm missing are: Encode::Detect, ExtUtils::CBuilder, ExtUtils::ParseXS,
Mail::ClamAV, Net::LDAP, and SAVI.  It reports my SA as version 3.002004

I'm running Perl v. 5.8.8 and sendmail 8.13.8

I'm happy to post any of my, MS or SA files (or
whatever else might be relevant upon request.

Any help or a kick in the right direction would be greatly appreciated.


Alden Levy
Engine No. 9, Inc.
130 West 57th Street, Suite 2F
New York, NY 10019
(212) 981-1122
(212) 504-9598 (fax)

More information about the MailScanner mailing list