Up2date perl problem package perl-5.8.5-36.el4_6.3 is already installed

Glenn glenn at mail.txwes.edu
Mon Feb 23 16:12:49 GMT 2009

I'm afraid I must agree with your analysis.  Red Hat does not immediately 
update its Perl packages to the current version, opting instead to patch the 
version in place.  So if we alter Red Hat's Perl by adding modules from a 
third party, up2date (the Red Hat EL3 and EL4 updater) has difficulty 
distinguishing the version.  I am having the same problem with Red Hat EL3, 
which uses perl-5.8.0-98.EL3.

And yes, rpm indicates that this version is installed.  The thing is, up2date 
should not be trying to install it if it is already installed.  A workaround 
is to configure up2date to skip "perl*".  This will allow up2date to update 
all other packages, but of course will prevent Red Hat's Perl patches from 
being applied.

I have tried forcing the reinstall of Perl from the Red Hat rpm.  This fixes 
up2date, but breaks MailScanner/ClamAV.

I'm not sure what the solution is.  Possibly someone could figure out which 
Perl module updates are causing up2date to balk and remove them from the 
MailScanner updates.   -Glenn.

---------- Original Message -----------
From: Remco Barendse <mailscanner at barendse.to>
To: MailScanner mailing list <mailscanner at lists.mailscanner.info>
Sent: Mon, 23 Feb 2009 09:48:07 +0100 (CET)
Subject: Up2date perl problem package perl-5.8.5-36.el4_6.3 is already 

> I am running rhel-i386-es-4 and i have a problem running up2date :
> Name                                    Version        Rel
> ----------------------------------------------------------
> perl                                    5.8.5          36.el4_6.3 i386
> Testing package set / solving RPM inter-dependencies...
> RPM package conflict error.  The message was:
> Test install failed because of package conflicts:
> package perl-5.8.5-36.el4_6.3 is already installed
> I did some googling, and i found a message stating that the perl 
> error is caused by a perl module MailScanner installed unfortunately 
> no solution. The remark there was that they contacted RedHat for 
> support and then the problem got solved.
> Now i could do the same but unfortunately this is a server i am 
> supporting on the other side of the world and the support contract 
> is with RedHat in Japan so contacting them is not so easy for me.  
> Some other post suggested to try and force uninstall of perl and 
> then re-installing it, however i have never tried this before and i 
> am pretty scared of messing up a production server i have extremely 
> difficult physical access to.
> If the problem is indeed caused by a perl module MailScanner 
> installed, does anybody know how to solve this problem?
> Thanks!!
> -- 
> MailScanner mailing list
> mailscanner at lists.mailscanner.info
> http://lists.mailscanner.info/mailman/listinfo/mailscanner
> Before posting, read http://wiki.mailscanner.info/posting
> Support MailScanner development - buy the book off the website!
------- End of Original Message -------

More information about the MailScanner mailing list