Problem installing new version of Sophos

Howard Robinson Howard at
Wed Apr 1 09:46:02 IST 2009

I am trying to install the latest Sophos.
I am using the same method I have used for a few years and not had problems until this time.
(I know MailScanner needs updating as it's a year or so old - it's on  a long list of jobs to do!) 

I have downloaded the file to /tmp and run /usr/sbin/Sophos.install
I get the following out put.

[root at server tmp]# /usr/sbin/Sophos.install

If you are trying to install Sophos version 5,
then please expand the tar file with a command like
    tar xzf sav-linux-5-i386.tgz
    cd sophos-av
Then run me again!

Press return to continue, or Ctrl-C to escape.

Clearing out old default Sophos installation libraries
Uncompressing Sophos distribution
Clearing out unpacked distribution
Unpacking distribution
Installing Sophos for MailScanner
Sophos Anti-Virus installation utility [Linux/Intel]
Copyright (c) 1998-2008 Sophos Plc, Oxford, England. All rights reserved.

Error: This is the wrong version of Sophos Anti-Virus for your version of
       Linux. Use the Linux on Intel (using libc6) (glibc2.2 and above) version
Creating links so Perl-SAVI module compiles

Fetching latest IDE virus identities from 
Could not calculate Sophos version number,  at /usr/lib/MailScanner/sophos-autoupdate line 152.
[root at server tmp]# /
It is the right version according to the note I have done on previous updates - I tried the glibc version to check and that failed with the same error!

Any Pointers on this?
I'll have a trawl on the web now but thought someone might be able to point me directly to the correction of problem.



Howard Robinson,
(Senior Technical Development Officer),
Harper Adams University College,
Shropshire ,
TF10 8NB.

Tel. Direct 01952 815253
Tel. Switch Board 01952 820280
Fax 01952 814783
Email hrobinson at 

More information about the MailScanner mailing list