Multiple confusions on my part.

Martin.Hepworth martinh at
Fri Sep 26 15:28:09 IST 2008


See below

Martin Hepworth
Snr Systems Administrator
Solid State Logic
Tel: +44 (0)1865 842300

> -----Original Message-----
> From: mailscanner-bounces at
> [mailto:mailscanner-bounces at] On Behalf
> Of Steve Campbell
> Sent: 26 September 2008 14:32
> To: mailscanner at
> Subject: Multiple confusions on my part.
> I've started seeing multiple timeouts with Spamassassin, and
> posted earlier about this. I got some good advice, and tried
> running some of the recommendations.
> Some of the problems I'm seeing :
> When I run MailScanner --debug --debug-sa
> I get some of the following errors that I can't figure out
> 08:59:37 [31687] dbg: async: starting: DNSBL-TXT,
> (timeout 15.0s, min 3.0s)
> 08:59:37 [31687] dbg: async: starting: DNSBL-A,
> (timeout 15.0s, min 3.0s)
> I can't seem to find where to turn these off or zero the score.

Give them a zero score in /etc/mail/spamassassin/mailscanner.conf. See /var/lib/spamassassin/<version>/updates_spamassassin_org/ for what RBL's it uses by default. I only run a couple here. Also usual advice of make sure the mailscanner host is running a local caching nameserver!

> I also see in the output the following:
> 08:59:39 /usr/local/bin/clamscan: unrecognized option
> `--unrar=/usr/bin/unrar'
> 08:59:39 ERROR: Unknown option passed.
> 08:59:39 ERROR: Can't parse the command line
> I have commented out the relevant lines in
> /usr/lib/MailScanner/clamav-wrapper but still get the errors
> as though they are still there.
> Also, when I run "/etc/rc.d/init.d/MailScanner reload", I get
> the following warning/error
> Reloading MailScanner workers:
>          MailScanner:       kill -2544: No such process

You got a bad process-id in there, manually kill the MS processes I'd suggest.

>                                                            [
> OK  ] When I run "/etc/rc.d/init.d/MailScanner status", I get
> the following warning/error
> Checking MailScanner daemons:
>          MailScanner:                                      [  OK  ]
>          incoming sendmail: head: /var/run/
> No such file or directory
>                                                            [FAILED]
>          outgoing sendmail:                                [  OK  ]
> There is indeed no such file, but there is a

Check the setup of sendmail - two sendmails, writing pids to correct files etc

> Plenty of problems, and I'm sure these old eyes just aren't
> seeing the fix.
> Any help would be greatfully appreciated.
> Steve Campbell
> --
> MailScanner mailing list
> mailscanner at
> Before posting, read
> Support MailScanner development - buy the book off the website!

Confidentiality : This e-mail and any attachments are intended for the 
addressee only and may be confidential. If they come to you in error 
you must take no action based on them, nor must you copy or show them 
to anyone. Please advise the sender by replying to this e-mail 
immediately and then delete the original from your computer.
Opinion : Any opinions expressed in this e-mail are entirely those of 
the author and unless specifically stated to the contrary, are not 
necessarily those of the author's employer.
Security Warning : Internet e-mail is not necessarily a secure 
communications medium and can be subject to data corruption. We advise 
that you consider this fact when e-mailing us. 
Viruses : We have taken steps to ensure that this e-mail and any 
attachments are free from known viruses but in keeping with good 
computing practice, you should ensure that they are virus free.

Red Lion 49 Ltd T/A Solid State Logic
Registered as a limited company in England and Wales 
(Company No:5362730)
Registered Office: 25 Spring Hill Road, Begbroke, Oxford OX5 1RU, 
United Kingdom

More information about the MailScanner mailing list