Multiple confusions on my part.

Steve Campbell campbell at
Fri Sep 26 14:31:53 IST 2008

I've started seeing multiple timeouts with Spamassassin, and posted 
earlier about this. I got some good advice, and tried running some of 
the recommendations.

Some of the problems I'm seeing :

When I run MailScanner --debug --debug-sa

I get some of the following errors that I can't figure out

08:59:37 [31687] dbg: async: starting: DNSBL-TXT, (timeout 15.0s, min 3.0s)
08:59:37 [31687] dbg: async: starting: DNSBL-A, (timeout 15.0s, min 3.0s)

I can't seem to find where to turn these off or zero the score.

I also see in the output the following:

08:59:39 /usr/local/bin/clamscan: unrecognized option 
08:59:39 ERROR: Unknown option passed.
08:59:39 ERROR: Can't parse the command line

I have commented out the relevant lines in 
/usr/lib/MailScanner/clamav-wrapper but still get the errors as though 
they are still there.

Also, when I run "/etc/rc.d/init.d/MailScanner reload", I get the 
following warning/error

Reloading MailScanner workers:
         MailScanner:       kill -2544: No such process
                                                           [  OK  ]
When I run "/etc/rc.d/init.d/MailScanner status", I get the following 

Checking MailScanner daemons:
         MailScanner:                                      [  OK  ]
         incoming sendmail: head: /var/run/ No such file 
or directory
         outgoing sendmail:                                [  OK  ]

There is indeed no such file, but there is a

Plenty of problems, and I'm sure these old eyes just aren't seeing the fix.

Any help would be greatfully appreciated.

Steve Campbell

More information about the MailScanner mailing list