Can't install CentOS 5.2 update?

Dave Jones davejones70 at
Wed Jun 25 15:38:29 IST 2008

A more simple method that I use is:

# yum -y update (this will fail with the conflicts but download the packages
into the yum cache for the rpm --force command below)
# yum -y update --exclude=perl*
# cd /var/cache/yum/rpmforge/packages
# rpm -Uhv --force perl*
# reboot  (if needed to get on a new kernel -- or just restart MailScanner)

You don't have to reinstall MailScanner everytime you get an updated perl
module conflict.


>seems to have worked for me as well.


>Randal, Phil wrote:
>> Don't panic:
>> First off, make sure you have the latest MailScanner to hand to
>> reinstall.
>> service MailScanner stop
>> service MailScanner startin
>> rpm -e perl-IO
>> rpm -e perl-Math-BigInt
>> rpm -e perl-Math-BigRat
>> rpm -e perl-bignum
>> (and any other perl modules it complains about)
>> yum update perl
>> ... Reinstall MailScanner
>> service MailScanner restart
>> yum upgrade
>> And reboot when it is all done
>> Worked for me.

Dave Jones
-------------- next part --------------
An HTML attachment was scrubbed...

More information about the MailScanner mailing list