MS busted! Please Help

lists at lists at
Tue Jul 22 11:13:06 IST 2008

I cant seem to uninstall some perl modules that the MS install script seems
to indicate a conflict with now? 

Is there anyway to force the MS install script to install all its own perl

.....from install of perl-MIME-Base64-3.07-1 conflicts with file from
package perl-5.8.8-10.el5_2.3
but if I run "yum remove perl-MIME-Base64" it does not seem to be
installed? Se below

I have certainly hooped perl so need to somehow start clean

root at gateway:~# yum remove perl-MIME-Base64
Loading "fastestmirror" plugin
Setting up Remove Process
Loading mirror speeds from cached hostfile
 * 4PSA:
 * virtualmin:
 * virtualmin-universal:
 * rpmforge:
 * base:
 * updates:
 * addons:
 * extras:
No Match for argument: perl-MIME-Base64
No Packages marked for removal

On Tue, 22 Jul 2008 10:42:55 +0100, Jason Ede
<J.Ede at> wrote:
> ________________________________________
> From: mailscanner-bounces at
> [mailscanner-bounces at] On Behalf Of
> lists at [lists at]
> Sent: 22 July 2008 10:11
> To: MailScanner discussion
> Subject: Re: MS busted! Please Help
> Yes I do run mailwatch and have tested the connection from the MS server
> to
> the mysql server (not on same machine). I took the same credntials right
> from MW's conf.php and tested the connection to mysql and it works
> root at gateway:~# mysql -h -u mailwatch -p
> Enter password:
> Welcome to the MySQL monitor.  Commands end with ; or \g.
> Your MySQL connection id is 9696
> Server version: 5.0.51a-community-log MySQL Community Edition (GPL)
> Type 'help;' or '\h' for help. Type '\c' to clear the buffer.
> mysql>
> I also had many errors on the MW install/upgrade dealing with various
> modules like below.
> file /usr/share/man/man3/Test::Builder::Tester::Color.3pm.gz from install
> of perl-Test-Simple-0.70-1 conflicts with file from package
> perl-5.8.8-10.el5_2.3
> The full list of the ones returning errors when running the MW install
> script are
> perl-ExtUtils-MakeMaker
> perl-MIME-Base64
> perl-Scalar-List-Utils
> perl-Storable
> perl-Getopt-Long
> perl-Time-HiRes
> perl-Test-Harness
> perl-Test-Simple
> perl-Sys-Syslog
> perl-IO
> perl-Math-BigInt
> perl-Math-BigRat
> perl-bignum
> I tried to uninstall most and re-run the installer but for some reason
> "rpm
> -e" seemd to think that some were not installed?
> I dont know where to go from here?
> try yum remove perl-bignum etc... On my systems CentOS since upgrade to
> 5.2 I need to do that, run yum update and then reinstall MailScanner to
> make sure its all happy...
> Does MailScanner start up ok if you turn off the mailwatch functions?
> Jason
> --
> MailScanner mailing list
> mailscanner at
> Before posting, read
> Support MailScanner development - buy the book off the website!

More information about the MailScanner mailing list