mailscanner install... mailtools requires perl 5.8 still?

shuttlebox shuttlebox at
Thu Apr 10 08:04:46 IST 2008

On Thu, Apr 10, 2008 at 3:27 AM, Bob Jones <bob.jones at> wrote:
> Hey all,
>         I have a user I'm supporting running Solaris 9.  He's trying to
> install version 4.68.8 and the installer is running into the error of
> mailtools requiring perl 5.8 and Solaris 9 only comes with 5.6.  (I know the
> previous has probably all been covered before... sorry.)
>         I found some discussion in the archives about the above fact in the
> "MailScanner --lint doesn't check Eicar virus - OK here!" thread, but never
> came across any final solution as to what to do about this problem for
> Solaris.  Did a solution other than "find some way to use perl 5.8" ever
> present itself?

You could always use the Blastwave packages. We're only at MailScanner
4.65 at the moment because we also need a minor Perl update, it should
all be resolved in about a week.

What you could do is to:

# pkg-get -i mailscanner

That would get MS 4.65 installed with all dependencies. You can then
download MS 4.68 from our testing area and apply it as usual with
pkgadd. You would also need Perl from testing.,REV=2008.04.09-SunOS5.8-all-CSW.pkg.gz,REV=2008.03.25-SunOS5.8-sparc-CSW.pkg.gz,REV=2008.03.25-SunOS5.8-i386-CSW.pkg.gz

If you're not familiar with Blastwave you can get started here:


More information about the MailScanner mailing list