No Logging to Syslog: MailScanner 4.65.3-1 on Solaris 9

Mr jeremy pennington jeremypennington at
Tue Nov 13 02:15:00 GMT 2007

----- Original Message ----
From: shuttlebox <shuttlebox at>
To: MailScanner discussion <mailscanner at>
Sent: Monday, November 12, 2007 2:18:17 AM
Subject: Re: No Logging to Syslog: MailScanner 4.65.3-1 on Solaris 9

On Nov 12, 2007 3:09 AM, Mr jeremy pennington
<jeremypennington at> wrote:
> I upgraded to MailScanner 4.65.3-1 last night and since then MailScanner has not logged any messages to syslog. MailWatch shows messages are being processed as normal and I have verified they are.  So I tried copying from the prior version installed (which was 4.54.6) to the new version and restarting MailScanner. This time the standard start up messages were recorded to syslog, but no messages were logged about mail being processed, in fact this disabled mail from being processed (it just stayed in the queue). So I reverted back and everything seems to be working again, except no logs from MailScanner are appearing in syslog. Any thoughts?

Look in for "setlogsock" and compare the differences between
the working version and the new. My guess is that the socket type has
changed. You will also find the same settings in the autoupdate
scripts for the virus scanners.

Also make sure that the syslog daemon listens to remote connections.

# netstat -a | grep syslog
      *.syslog                            Idle

As a Solaris user you might find it handy to check out the Blastwave
collection of software, I package MailScanner and it automagically
solves all dependencies for you. Clam, SpamAssassin and so on is also

Thanks Peter! 
Running netstat gives me the following:
# netstat -a | grep syslog
mail.32791           mail.syslog            Connected
mail.43133           mail.syslog            Connected
localhost.60230      localhost.syslog       Connected
localhost.60231      localhost.syslog       Connected
localhost.60258      localhost.syslog       Connected
localhost.60260      localhost.syslog       Connected
Comparing the the two, there is some differences for "setlogsock". I tried several different changes, but was not able to get anything to work. Any other thoughts?
Thanks for the info on blastware, I'll take a look at it.

Never miss a thing.  Make Yahoo your home page.

More information about the MailScanner mailing list