RPM File locations and .rpmmacros ...

Michael H. Warfield mhw at WittsEnd.com
Fri Sep 29 16:48:53 IST 2006

Hey all!

	Just got burned (actually, just figured out WHY I got burned) trying to
install (re-install) MailScanner.

	One system I have under my control seemed to install MailScanner (Ok...
I ran install.sh and then walked away - missed a BUNCH of "rpm not
found" error messages) but it would not run (various perl errors).  Use
to work but blew up when I upgraded to 4.55.  Weird, because this was
working fine on other systems.

	Discovered the problem...  I had, somewhat recently, created
a .rpmmacros file in my home directory for building some rpms under my
user id (I had been playing with OpenGroupware and OpenExchange).  To
install MailScanner, I ran "sudo -s" to jump to a superuser shell and,
when I ran install.sh, my .rpmmacros file caused the all the rpm's to be
built under my target directory.  The script could not then find them,
looking only in /usr/src/redhat/RPMS/*.

	Self inflicted injury, true, but, maybe, the install should be checking
to see where the rpm files are being built?  Check for ~/.rpmmacros or
run "rpmbuild --showrc" and look for %_topdir and/or %_rpmdir?  Yeah,
that gets ugly too, since you have to parse it (mine was "%_topdir
%(echo "$HOME")/rpmbuild") and expand it.  Or, maybe, dummy out
the .rpmmacros file somehow (uglier)?

Michael H. Warfield (AI4NB) | (770) 985-6132 |  mhw at WittsEnd.com
   /\/\|=mhw=|\/\/          | (678) 463-0932 |  http://www.wittsend.com/mhw/
   NIC whois: MHW9          | An optimist believes we live in the best of all
 PGP Key: 0xDF1DD471        | possible worlds.  A pessimist is sure of it!

-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 307 bytes
Desc: This is a digitally signed message part
Url : http://lists.mailscanner.info/pipermail/mailscanner/attachments/20060929/e087cf7e/attachment.bin

More information about the MailScanner mailing list