children are killing my server

DAve dave.list at
Thu Sep 7 05:47:12 IST 2006

mailscanner at wrote:
> OK,
> As some of you guys adviced me earlier, I installed MailWatch on my
> server (freebsd 6.1). Well, that is a nice package, thanks for that!!
>  I have only a small problem. I installed it earlier today and it
> seemed to work fine. I had some problems with the change between
> linux and Freebsd but I managed to make it work. After it worked
> great for about 3 hours the messages stopped appearing and after a
> few more time the server  got loaded more and more. I checked and I
> saw that MailScanner spawned 70 children (MailScanner.conf says
> max=5). They all spawned at different times in "ps". There was also
> no "MailWatch SQL" running anymore, even after I killed all child
> processes and restarted" I finally removed and
> from the
> /usr/local/lib/MailScanner/MailScanner/CustomFunctions/ dir and after
> that MailScanner worked fine again.
> Does anybody have any idea what is causing this? I know it's a bit
> off-topic, but I think, maybe one of you guys is using MailWatch with
> Freebsd too.
> Thanks,
> Roger

MailScanner 4.54.6
FreeBSD 4.x and 5.x

I experienced the same result, though the cause may be different. I have
a posting on the MailWatch list about it between me and Steve. What I
saw was that whenever I restarted MySQL (my mailwatch install is on a
remote server from my MailScanner installs) would hang when
MySQL went away. Once that happened it stopped working. Restarting
MailScanner left all the children using that MailWatch process behind. 
The more you restarted the worse it got.

Look for the thread in this list titled "Always Looked Up Last". Julian 
fixed that problem, MailScanner will pass over a function that fails 
now. Not sure what version he put the fix into.

Look for the thread in the MailWatch list titled "MailWatch SQL Logging"
Still no answer on this one, I just have to make sure I stop MailScanner 
before I restart my SQL server and all is well. Otherwise 
fails when it can't get port 11553 on startup.

Possibly those will help you.


Three years now I've asked Google why they don't have a
logo change for Memorial Day. Why do they choose to do logos
for other non-international holidays, but nothing for

Maybe they forgot who made that choice possible.

More information about the MailScanner mailing list