log is flotting with messages

redhat at techspace.nl redhat at techspace.nl
Mon Nov 20 19:00:43 GMT 2006

Quoting Glenn Steen <glenn.steen at gmail.com>:

> On 19/11/06, redhat at techspace.nl <redhat at techspace.nl> wrote:
>> Quoting Glenn Steen <glenn.steen at gmail.com>:
>>> On 19/11/06, Res <res at ausics.net> wrote:
>>>> On Sat, 18 Nov 2006, redhat at techspace.nl wrote:
>>>>> this is my output but i have no idea what it means exept that tere is a
>>>>> problem with spamassassin.
>>>>> [root at localhost ~]# spamassassin --lint
>>>>> [2982] warn: config: failed to parse line, skipping: dcc_path
>>>>> /usr/local/bin/dccproc
>>>>> [2982] warn: lint: 1 issues detected, please rerun with debug enabled for
>>>>> more information
>>>> Thats an "OK" error if you did not install dcc, you can ignore it, I
>>>> disabled it recently because its laggy to here.
>>> Right. If you don't use DCC, simply comment that line out (to avoid
>>> the error from the --lint). It's in your spam.assassin.prefs.conf file
>>> (also softlinked from /etc/mail/spamassassin/mailscanner.cf)
>>>>> [root at localhost ~]# MailScanner --lint
>>>>> Read 719 hostnames from the phishing whitelist
>>>>> MailScanner setting GID to  (89)
>>>>> MailScanner setting UID to  (89)
>>>> What MTA are you using?  89 is usually the user/group BSD allocates for
>>>> something like vpopmail, why are you setting run-as?
>>>> If you use sendmail strip it out. if you are using postfix, I can't help
>>>> you any further.
>>> Giving up on postmix are you, eh Res?:-). Furtunate us postmixers are
>>> ready to step into the fray:-D
>>>> There doesnt appear to be any problems with either, what value do you have
>>>> for  Max Children? should be 5 per REAL cpu (not HT'd).
>>> CC.
>>> What I'd like to see is the output of a debug run (for both
>>> MailScanner and SA)... Will just run through for one message.
>>> Have you implemented MailWatch too?
>>> --
>>> -- Glenn
>>> email: glenn < dot > steen < at > gmail < dot > com
>>> work: glenn < dot > steen < at > ap1 < dot > se
>>> --
>>> MailScanner mailing list
>>> mailscanner at lists.mailscanner.info
>>> http://lists.mailscanner.info/mailman/listinfo/mailscanner
>>> Before posting, read http://wiki.mailscanner.info/posting
>>> Support MailScanner development - buy the book off the website! -- Dit
>> How do i run a debug and no i have not implemented mailwatch
> Being slightly tipsy (yes, I *know* it's a Sunday, but we had the
> final (well...:-) performance with the choir today... And the usual
> post mortem/beer, snaps and sausages afterwards (Some Mendelssohn,
> Bainton and Vaughn Williams, for those interested in such:-),  can't
> say my precision is the best... Double-check everything with a
> MailScanner --help;-).
> IIRC (which is doubtful, considering my state:) you should run a
> "MailScanner --debug --debug-spamassassin" and send one message
> through. It'll output the debug info to the terminal you run it from,
> and then exit.
>> things so far no mail is transfered as long as i set the option
>> Use SpamAssassin = yes if i disable this option mailscanner works.
>> I can start SpamAssassin with /etc/init.d/SpamAssassin start and there
>> are no problems in the log.
>> My setup mta=postfix on fedora core 6
> Hm, Drew should chip in here:-).
>> lasts lines of the log these repaeats over and over.
>> Nov 19 15:26:48 localhost MailScanner[10323]: MailScanner E-Mail Virus
>> Scanner version 4.55.1 starting...
>> Nov 19 15:26:49 localhost MailScanner[10323]: Read 747 hostnames from
>> the phishing whitelist
>> Nov 19 15:26:50 localhost MailScanner[10323]: Using SpamAssassin   
>> results cache
>> Nov 19 15:26:50 localhost MailScanner[10323]: Connected to
>> SpamAssassin cache database
>> Nov 19 15:26:50 localhost MailScanner[10323]: Enabling SpamAssassin
>> auto-whitelist functionality...
>> Is there a problem with the white list.
>> I'm running the same setup on fedora core4 no problem.
>> any advise thanks jasper
> Gut feeling is that this is a permissions related problem. Did you set
> a User State Dir (in MailScanner.conf) for SA? If you become your
> postfix user and run spamassassin --lint, does that work? Does it work
> when running a message through (spamassassin -t <
> /path/to/message/file)? Usually the postfix user need you to specify a
> shell, as in
> su - postfix -s /bin/bash
> ... or similar. Check that the user can find and read things like
> bayes db files, AWL etc etc.

i ran the lint commants
spamassassin -D -p /etc/MailScanner/spam.assassin.prefs.conf --lint
output no problems
MailScanner --lint
Read 747 hostnames from the phishing whitelist
MailScanner setting GID to  (89)
MailScanner setting UID to  (89)
Checking for SpamAssassin errors (if you use it)...
Using SpamAssassin results cache
Connected to SpamAssassin cache database
perl: ldap-nss.c:1312: do_init: Bewering  
`cfg->ldc_uris[__session.ls_current_uri] != ((void *)0)' mislukt.

sorry output is dutch but vales at the last line's

What does this mean.

and yes i can run a message trou spamassasin and i made the spool dir  
read and write to anyone.

thanks jasper

Dit bericht is gescanned op virussen en andere gevaarlijke
inhoud door Dark Eagle mail scanner en lijkt schoon te zijn.

More information about the MailScanner mailing list