ClamAV messed up

Gerry gdoris at
Tue Nov 7 01:10:17 GMT 2006

-----Original Message-----
From: mailscanner-bounces at
[mailto:mailscanner-bounces at] On Behalf Of Res
Sent: November 6, 2006 19:44
To: MailScanner discussion
Subject: Re: ClamAV messed up

On Mon, 6 Nov 2006, Gerry wrote:

> I upgraded from FC 4 to FC 6 a short time ago.  I thought everything
> was working until I ran into problems with ClamAV and MailScanner:
> 1. MailScanner was continually restarting until I changed
> "clamavmodule" to "clamav" in MailScanner.conf
> 2. Running MailScanner --lint indicates that I have "clamav" in the
> conf file but MailScanner finds "clamavmodule" instead
> 3. Doing an upgrade_virus_scanners checks ClamAV but also generic.  I
> don't have generic listed anywhere
> 4. Running MailScanner -v shows that Mail::ClamAv is installed
> 5. Using CPAN to reinstall Mail::ClamAV says it is already installed.
> Doing a forced install fails at the make
> Inspite of all this ClamAV is scanning messages.  I'm using
> MailScanner
> 4.56.8-1 and ClamAV of rc2-99.  I know that's a rc level but I had the
> same problem with 0.88.5 and thought I'd try something different.
> I haven't a clue where to start on this.

Seen this a trillion times in upgrades, its not related to Fedora, its RHES,
suse, slackware and probably all others.
It will be a perl version conflict problem.

its ugly but run it all manually, can you paste the output where perl bails?


I got it working!

I removed ClamAV rc0.99 totally including the libclamav files.  I then
installed the latest release 0.88.6.  Once I had that installed I went back
and tried to reinstall Mail::ClamAV.  This time it worked.

I have now enabled clamavmodule in MailScanner.conf and am back to
normal...well, nearly.  For some reason update_virus_scanners still thinks
there is a generic virus scanner installed but I can live with that!

More information about the MailScanner mailing list