Mailscanner not scanning queue

Nate nate at
Wed Dec 13 17:39:26 GMT 2006

Hash: SHA1

I just installed MailScanner + Postfix on 6 servers running Debian
Sarge.  I installed from stable packages, so mailscanner is version
4.41.3-2 and postfix is 2.1.5-9.  I tried installing the latest
mailscanner from the unstable branch, but it has too many dependencies,
and if I fulfilled them, I'd be running unstable on the whole box
instead of stable.  I followed the directions I found at

OK, that said, here's my problem.  After starting mailscanner everything
appears to work fine... for a little while.  On every server Mailscanner
eventually just doesn't see messages that arrive in the queue any more.
 I do a postqueue -p and can see the messages waiting in the hold queue,
but mailscanner isn't doing anything with them.

I tried enabling Debug in the conf and running check_mailscanner.  That
runs fine, but since it quits right away I don't think it hits the
problem where it's not seeing new messages.

Does anyone have any ideas of things to try from here?  Any knows bugs
that I'm maybe hitting?  If so, how do I install the latest version on
Debian Sarge?

Version: GnuPG v1.4.2.2 (GNU/Linux)
Comment: Using GnuPG with Mozilla -

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3491 bytes
Desc: S/MIME Cryptographic Signature
Url :

More information about the MailScanner mailing list