Panda not working

Paul Welsh zen23003 at ZEN.CO.UK
Thu Mar 3 21:38:56 GMT 2005

Anyone managed to get panda working?

I'm running MailScanner 4.38.9 on RH9 with the pavcl program file dated 1
July 03.  I installed pavcl from rpm.

pavcl is in /usr/bin and I have the pav.sig signature file in
/usr/lib/panda.  The .sig file is dated today, so the autoupdate is working.

The /usr/lib/MailScanner/panda-wrapper file refers to /bin/pavcl rather than
/usr/bin/pavcl so I guess there's one potential problem.

The /etc/MailScanner/virus.scanners.conf file contains the line:

panda           /usr/lib/MailScanner/panda-wrapper      /usr

There's the following advice in virus.scanners.conf:

# You can test a -wrapper script with a command like this:
#      /usr/lib/MailScanner/f-secure-wrapper /opt/f-secure/fsav /tmp
# That command will attempt to scan /tmp using F-Secure. If it works you
# should see some sensible output. If it fails, you will probably just see
# an error message such as "Command not found" or similar.

I've tried the command:

/usr/lib/MailScanner/panda-wrapper /usr/bin/pavcl /tmp

Along with a whole load of permutations.  I've tried changing panda-wrapper
and virus.scanners.conf but all to no avail. I just get "Virus: 0" as the
response, even though there's a valid test file in the directory
that's being scanned and the equivalent f-prot command works fine.  Running
pavcl direct from the command line detects the eicar file.

------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the MAQ ( and
the archives (

Support MailScanner development - buy the book off the website!

More information about the MailScanner mailing list