Debian unstable error on 'MailScanner check'

Steve Waterman steve at
Thu Apr 28 14:53:17 IST 2005

System:  Debian unstable
Kernel:  2.6.11, custom
Mailscanner version:  4.40.11-1
CPU:  Intel Pentium III (Katmai) stepping 02, 450 Mhz
Memory:  512 MB
Filesystem:  EXT3
Perl:  revision 5 version 8 subversion 4
Characteristics of this binary (from libperl):
  Built under linux
  Compiled at Mar  8 2005 19:51:48

Apt-get sources are default and all updates have been applied 'apt-get
update' and 'apt-get upgrade'.


When running the command 'MailScanner check' or '/etc/init.d/MailScanner
start' I receive the following error:

Cannot open config file check, No such file or directory at
/usr/share/MailScanner/MailScanner/ line 592.
Compilation failed in require at /usr/sbin/MailScanner line 65.
BEGIN failed--compilation aborted at /usr/sbin/MailScanner line 65.

Line 592 in /usr/share/MailScanner/MailScanner/ refers to:

$fh->open("<$filename") or die "Cannot open config file $filename, $!";

Line 65 in /usr/sbin/MailScanner refers to:

use MailScanner::CustomConfig;

I have removed MailScanner via 'apt-get remove mailscanner --purge',
re-installed, edited the maintainer's /etc/MailScanner/MailScanner.conf
file, saved the file and tried using my previous MailScanner.conf file from
my previous working config.

The program did work correctly until the last 'apt-get upgrade'.  As a last
resort, I have done an 'apt-get dist-upgrade' yet continue to receive the
same error message.

Thank you!


------------------------ MailScanner list ------------------------
To unsubscribe, email jiscmail at with the words:
'leave mailscanner' in the body of the email.
Before posting, read the Wiki ( and
the archives (

Support MailScanner development - buy the book off the website!

More information about the MailScanner mailing list